The Fedora User Guide is focused on the end-user looking to accomplish standard desktop computer user tasks, such as browsing the web, reading and sending email, and doing office productivity work.
Preface vii
  1. Document Conventions ........................................................................................................ vii
  1.1. Typographic Conventions ................................................................................................ vii
  1.2. Pull-quote Conventions .................................................................................................... viii
  1.3. Notes and Warnings ........................................................................................................... ix
  2. We Need Feedback! ................................................................................................................... ix

Introduction xi
  1. About this document ........................................................................................................... xi

1. The Fedora desktops 1

2. Logging into the desktop 3
  2.1. Logging in ....................................................................................................................... 3
  2.2. Logging in: a technical explanation ................................................................................ 4
  2.3. I Cannot Login: HELP! ................................................................................................ 4

3. Tour of the GNOME desktop 5
  3.1. The GNOME desktop ....................................................................................................... 5
  3.1.1. The top menu panel ................................................................................................... 5
  3.1.2. The desktop area ....................................................................................................... 10
  3.1.3. The window list panel ............................................................................................... 11

4. Tour of the KDE desktop 13
  4.1. The KDE desktop ............................................................................................................ 13
  4.2. The KDE desktop area .................................................................................................... 14
  4.3. The KDE panel ................................................................................................................ 14
  4.3.1. The Kickoff Application Launcher ............................................................................. 15

5. Tour of the Xfce desktop 17
  5.1. The Xfce 4 desktop ......................................................................................................... 17
  5.1.1. The Xfce 4 menu panel ............................................................................................. 18
  5.1.2. The Xfce 4 desktop area .......................................................................................... 18
  5.1.3. The Xfce 4 window list panel ..................................................................................... 19

6. Media 21
  6.1. ISO images ...................................................................................................................... 21
  6.2. Writing CDs or DVDs ..................................................................................................... 21
    6.2.1. Using CD/DVD Creator to burn media in GNOME ...................................................... 22
    6.2.2. Using K3b to burn media in KDE .................................................................................. 22
    6.2.3. Using GnomeBaker in Gnome .................................................................................... 23
  6.3. Making bootable USB media ........................................................................................... 23
    6.3.1. USB image creation in Windows .................................................................................. 24
    6.3.2. USB image creation in Fedora .................................................................................. 24

7. Connecting to the Internet 27
  7.1. GNOME .......................................................................................................................... 27
  7.2. KDE ................................................................................................................................. 27
  7.3. Configuring PPPoE .......................................................................................................... 27
  7.4. DHCP connection ............................................................................................................ 27
  7.5. Static IP address .............................................................................................................. 27
  7.6. NetworkManager ............................................................................................................ 28
  7.7. Wireless ........................................................................................................................... 28
  7.8. Remote desktop ............................................................................................................... 29

8. Accessing the Web 31
8.1. Browsing web pages ................................................................. 31
  8.1.1. Using Firefox ................................................................. 31
  8.1.2. Using Konqueror ......................................................... 32
8.2. Transferring files ................................................................. 33
  8.2.1. Using FileZilla ............................................................. 33
  8.2.2. FTP on the command line ............................................. 34
9. Communications ................................................................. 37
  9.1. Evolution ........................................................................... 37
    9.1.1. Configuring Evolution ............................................... 37
    9.1.2. Using Evolution ....................................................... 38
  9.2. Thunderbird .................................................................... 38
    9.2.1. Configuring Thunderbird .......................................... 38
    9.2.2. Moving your Thunderbird profile data from Windows to Fedora ................. 39
    9.2.3. Using Thunderbird .................................................. 41
  9.3. Claws Mail ....................................................................... 42
    9.3.1. Configuring Claws Mail ............................................ 42
    9.3.2. Using Claws Mail .................................................. 43
  9.4. Kmail ............................................................................... 44
    9.4.1. Configuring Kmail ................................................... 44
    9.4.2. Using Kmail .......................................................... 44
  9.5. Pidgin ............................................................................. 45
    9.5.1. Configuring Pidgin .................................................. 45
    9.5.2. Using Pidgin .......................................................... 45
  9.6. Kopete ............................................................................ 46
    9.6.1. Configuring Kopete ................................................ 46
  9.7. XChat ............................................................................. 47
    9.7.1. Configuring XChat .................................................. 47
    9.7.2. Using XChat .......................................................... 47
  9.8. Konversation ................................................................. 47
    9.8.1. Configuring Konversation ......................................... 47
    9.8.2. Using Konversation ................................................ 48
  9.9. ChatZilla ......................................................................... 48
    9.9.1. Installing ChatZilla .................................................. 48
    9.9.2. Configuring ChatZilla .............................................. 48
    9.9.3. Using ChatZilla ...................................................... 49
10. Office tools .......................................................... 51
  10.1. OpenOffice.org applications .......................................... 51
    10.1.1. OpenOffice.org Impress ......................................... 51
    10.1.2. OpenOffice.org Calc ............................................. 52
    10.1.3. OpenOffice.org Writer ........................................... 53
  10.2. KOffice .......................................................................... 55
    10.2.1. KPresenter ............................................................ 55
    10.2.2. KSpread ............................................................... 57
    10.2.3. KWord ................................................................. 58
  10.3. GNOME office applications .......................................... 60
    10.3.1. AbiWord ............................................................... 60
    10.3.2. Gnumeric ............................................................. 61
    10.3.3. gLabels ............................................................... 62
11. Financial software ........................................................... 65
  11.1. GnuCash .......................................................... 65
Preface

1. Document Conventions
This manual uses several conventions to highlight certain words and phrases and draw attention to specific pieces of information.

In PDF and paper editions, this manual uses typefaces drawn from the Liberation Fonts\(^1\) set. The Liberation Fonts set is also used in HTML editions if the set is installed on your system. If not, alternative but equivalent typefaces are displayed. Note: Red Hat Enterprise Linux 5 and later includes the Liberation Fonts set by default.

1.1. Typographic Conventions
Four typographic conventions are used to call attention to specific words and phrases. These conventions, and the circumstances they apply to, are as follows.

Mono-spaced Bold
Used to highlight system input, including shell commands, file names and paths. Also used to highlight keycaps and key combinations. For example:

To see the contents of the file my\_next\_bestselling\_novel in your current working directory, enter the \texttt{cat my\_next\_bestselling\_novel} command at the shell prompt and press \texttt{Enter} to execute the command.

The above includes a file name, a shell command and a keycap, all presented in mono-spaced bold and all distinguishable thanks to context.

Key combinations can be distinguished from keycaps by the hyphen connecting each part of a key combination. For example:

Press \texttt{Enter} to execute the command.

Press \texttt{Ctrl+Alt+F1} to switch to the first virtual terminal. Press \texttt{Ctrl+Alt+F7} to return to your X-Windows session.

The first paragraph highlights the particular keycap to press. The second highlights two key combinations (each a set of three keycaps with each set pressed simultaneously).

If source code is discussed, class names, methods, functions, variable names and returned values mentioned within a paragraph will be presented as above, in mono-spaced bold. For example:

File-related classes include \texttt{filesystem} for file systems, \texttt{file} for files, and \texttt{dir} for directories. Each class has its own associated set of permissions.

Proportional Bold
This denotes words or phrases encountered on a system, including application names; dialog box text; labeled buttons; check-box and radio button labels; menu titles and sub-menu titles. For example:

\(^1\) https://fedorahosted.org/liberation-fonts/
Choose **System** → **Preferences** → **Mouse** from the main menu bar to launch **Mouse Preferences**. In the **Buttons** tab, click the **Left-handed mouse** check box and click **Close** to switch the primary mouse button from the left to the right (making the mouse suitable for use in the left hand).

To insert a special character into a **gedit** file, choose **Applications** → **Accessories** → **Character Map** from the main menu bar. Next, choose **Search** → **Find...** from the **Character Map** menu bar, type the name of the character in the **Search** field and click **Next**. The character you sought will be highlighted in the **Character Table**. Double-click this highlighted character to place it in the **Text to copy** field and then click the **Copy** button. Now switch back to your document and choose **Edit** → **Paste** from the **gedit** menu bar.

The above text includes application names; system-wide menu names and items; application-specific menu names; and buttons and text found within a GUI interface, all presented in proportional bold and all distinguishable by context.

### Mono-spaced Bold Italic or Proportional Bold Italic

Whether mono-spaced bold or proportional bold, the addition of italics indicates replaceable or variable text. Italics denotes text you do not input literally or displayed text that changes depending on circumstance. For example:

To connect to a remote machine using ssh, type `ssh username@domain.name` at a shell prompt. If the remote machine is `example.com` and your username on that machine is `john`, type `ssh john@example.com`.

The `mount -o remount file-system` command remounts the named file system. For example, to remount the `/home` file system, the command is `mount -o remount /home`.

To see the version of a currently installed package, use the `rpm -q package` command. It will return a result as follows: `package-version-release`.

Note the words in bold italics above — `username`, `domain.name`, `file-system`, `package`, `version` and `release`. Each word is a placeholder, either for text you enter when issuing a command or for text displayed by the system.

Aside from standard usage for presenting the title of a work, italics denotes the first use of a new and important term. For example:

Publican is a *DocBook* publishing system.

### 1.2. Pull-quote Conventions

Terminal output and source code listings are set off visually from the surrounding text.

Output sent to a terminal is set in **mono-spaced** **roman** and presented thus:
Source-code listings are also set in mono-spaced roman but add syntax highlighting as follows:

```java
package org.jboss.book.jca.ex1;
import javax.naming.InitialContext;

public class ExClient {
    public static void main(String args[]) throws Exception {
        InitialContext iniCtx = new InitialContext();
        Object ref = iniCtx.lookup("EchoBean");
        EchoHome home = (EchoHome) ref;
        Echo echo = home.create();
        System.out.println("Created Echo");
        System.out.println("Echo.echo('Hello') = " + echo.echo("Hello"));
    }
}
```

1.3. Notes and Warnings

Finally, we use three visual styles to draw attention to information that might otherwise be overlooked.

**Note**

Notes are tips, shortcuts or alternative approaches to the task at hand. Ignoring a note should have no negative consequences, but you might miss out on a trick that makes your life easier.

**Important**

Important boxes detail things that are easily missed: configuration changes that only apply to the current session, or services that need restarting before an update will apply. Ignoring a box labeled 'Important' won't cause data loss but may cause irritation and frustration.

**Warning**

Warnings should not be ignored. Ignoring warnings will most likely cause data loss.

2. We Need Feedback!

If you find a typographical error in this manual, or if you have thought of a way to make this manual better, we would love to hear from you! Please submit a report in Bugzilla: [http://bugzilla.redhat.com/bugzilla/](http://bugzilla.redhat.com/bugzilla/) against the product Fedora Documentation.

When submitting a bug report, be sure to mention the manual's identifier: `user-guide`
If you have a suggestion for improving the documentation, try to be as specific as possible when describing it. If you have found an error, please include the section number and some of the surrounding text so we can find it easily.
Introduction

Welcome to the Fedora 12 User Guide! This guide is intended for users who have a working Fedora 12 system and are able to use a mouse and keyboard.

This guide explains:
• The different desktops available to the Fedora user
• How to login to your computer
• The layout of three Fedora desktops (GNOME, KDE, and Xfce)
• How to use the file and system navigator
• How to use the email client
• How to use the instant messenger client
• How to use the web browser
• How to use the OpenOffice.org office suite
• How to customize your new Fedora desktop
• How to manage and update software

1. About this document

Volunteer contributors from the Fedora Documentation Project create this guide for each release of Fedora. If you have questions or suggestions about Fedora’s documentation, or if you would like to help document Fedora, please visit the Fedora Documentation Project web site1.


Thank you for choosing Fedora.

1 https://fedoraproject.org/wiki/DocsProject
2 http://docs.fedoraproject.org/install-guide/f/
The Fedora desktops

In contrast to most proprietary operating systems, Fedora 12 has several desktop environments or desktops that can display and launch available applications and manage the overall appearance of the screen. The desktop environment is sometimes referred to as the Graphical User Interface (GUI).

Three widely-used desktops included with Fedora 12 are:

- GNOME, which focuses on simplicity
- KDE, which includes a large collection of applications and customization features
- Xfce, a desktop with low hardware requirements, suitable for older computers

More Desktop Environments Exist!
Fedora's extensive repository of software offers other desktops as well, such as Fluxbox\(^1\) (minimalist desktop), Sugar\(^2\) (the desktop environment for the OLPC XO), and LXDE\(^3\).

To learn how to browse and install software from the repository, refer to Chapter 17, Managing software.

With few exceptions, applications included with a particular desktop environment run in other environments too. For instance, the OpenOffice.org office suite runs on all three major desktop environments.

Some applications are created specifically for a particular desktop environment. For example, each major desktop has a preferred text editor. GNOME uses Gedit and KDE supplies Kedit, but you can install and use these in either environment.

Fedora provides a wide choice of applications to browse the World Wide Web, create documents, and display and edit photos. This guide describes the most commonly installed applications on the most common desktop environments, as well as the useful alternatives.
Chapter 2.

Logging into the desktop

This section of the Fedora User Guide explains how to identify yourself (or log in) to your system. During the post-installation process, you created an identity with a user name and a password, called an account. If you have forgotten any of your user account details, refer to Section 2.3, “I Cannot Login: HELP!”. For additional information about the login process, refer to the section Section 2.2, “Logging in: a technical explanation”.

2.1. Logging in

When you restart or turn on your computer, it goes through a process called booting. During the boot process, your computer hardware powers on, performs a series of self-tests, and loads the operating system. Immediately after the computer has finished booting, the login screen appears. The login screen displays one or more user names, depending on the number of user accounts present.

To log in to your account

1. Enter your username, using one of the following methods:
   - Type your username and then press the Enter key. The username is case sensitive (capitalization matters; A is not the same as a).
   - Click on your username in the list of choices.

2. Select your desktop environment

   This step is optional
   You do not normally need to choose a desktop. If you skip this step, Fedora will load the default desktop environment for your computer.

   To use a desktop environment other than the default choice, use the Desktop combo box on the bottom of the screen to select the desktop you wish to load before you enter your password. The default is usually GNOME; refer to Chapter 1, The Fedora desktops for other choices.

3. Enter your password in the text box and press the Enter key. Like your username, your password is case sensitive.

   Keep your password secret!
   To keep your password secret, the password field displays a dot for every character entered. As with any password, keep your account password private. Do not share it with anyone or write it down in plain view.

4. The desktop environment now loads. In some desktop environments, a small box containing a logo and some icons called a splash screen may temporarily appear. When your splash screen (if you have one) disappears, your desktop is ready for use. You can now launch applications to access the Internet, manage files, and play media. These tasks are described in the following chapters.
2.2. Logging in: a technical explanation

Fedora is a multi-user operating system. Multiple users, each with different access privileges, can be logged into the computer at the same time.

During installation, you provided a password for the system administrator account, sometimes called the superuser. The user name for this account is root.

After installation, Fedora asked you to set up a normal user account. Use that account, or any other such normal account, for daily use of the system, and the root account for administrative and maintenance tasks.

This design has many benefits:

- Limited privileges reduce the possibility of doing significant damage to the entire system.
- Each user account has individual settings.
- Each user account maintains its data separate and private from others.
- A problem in one user account does not put the entire system at risk.

Do not log in as root!

Do not use the root account for routine purposes. A normal user account can run all the desktop applications, and greatly increases your security and safety. Applications that require root privileges prompt you for the root password when they need it. There is no need to log in as root to use them.

2.3. I Cannot Login: HELP!

A common mistake during login is accidentally having the Caps Lock key turned on. This situation can cause the login process to fail because usernames and passwords are case sensitive. If problems persist, re-enter your username and password a few times to ensure that you have typed them correctly.

Recovering the password for a user account is not a difficult process, but it is beyond the scope of this guide. You may wish to ask for help on user forums or chat rooms for further assistance.
Chapter 3.

Tour of the GNOME desktop

This chapter introduces the GNOME desktop in Fedora. The desktop becomes easier to use after you know some of the common terminology used, beginning with the GNOME desktop.

If you installed Fedora 12 from the Fedora 12 Live image, whether for Intel or compatible (i686), PowerPC (ppc), or 64-bit (x86_64), GNOME is the installed desktop. You can find details of two alternative desktops in Chapter 4, Tour of the KDE desktop and Chapter 5, Tour of the Xfce desktop.

3.1. The GNOME desktop

![Figure 3.1. The GNOME desktop](image)

The GNOME desktop has three distinct areas. From top to bottom, they are:
- the top menu panel (the gray bar at the top).
- the desktop area (the workspace area in the center that fills most of the screen).
- the window list panel (the gray bar at the bottom).

3.1.1. The top menu panel

This panel stretches across the top of the screen. The left side contains:
- the applications menu.
• the places menu.

• the system menu.

• program icons for the default email program, web browser, and reminder notes.

The right side of the panel is home to:
• the notification area.

• a volume control.

• the user switch area.

• a clock and calendar.

Function description
If you hold the mouse pointer over the menu text or an icon, a brief description of its function appears. If you click one of these icons, that application starts.

3.1.1.1. The Applications menu
This menu contains a categorized list of installed applications, which are updated as necessary when software is installed or removed. When you click on Applications a drop-down list appears. The default list installed is:
• Accessories
• Games
• Graphics
• Internet
• Office
• Programming
• Sound & Video
• System Tools

3.1.1.2. The Places menu
This menu is divided into four subsections.
• The first subsection allows quick access to commonly accessed folders, and makes it easy to keep your file system organized. These links are:
  • Home Folder where your personal files are kept by default.

  • Desktop, a folder within your Home Folder where the files and folders that appear on your desktop are stored.

  • Documents, a folder within your Home Folder intended as a place for you to store documents, such as those that you might have created with a word processor or spreadsheet program.
• **Music**, a folder within your **Home Folder** intended as a place for you to store music files.

• **Pictures**, a folder within your **Home Folder** intended as a place for you to store photographs and other pictures.

• **Videos**, a folder within your **Home Folder** intended as a place for you to store videos.

• **Download**, a folder within your **Home Folder** intended as a place for you to store miscellaneous files that you have downloaded from the Internet.

• The second subsection allows quick access to:
  • the **Computer** window, which allows you to browse the computer's files and all data storage attached to the computer.

• The third section provides links to tools that help you browse and manage network locations.
  • **Network** allows you to view the networks that your computer is attached to, and to access files and other resources available through those networks.

• **Connect to Server** allows you to create connections to public or local networks.

• The fourth section helps you quickly access any file on the system.
  • **Search for files** allows you to search for files stored on your computer.

  • **Recent Documents** lists the documents and folders recently accessed.

### 3.1.1.3. The System menu

This menu is divided into three subsections.

• The first provides access to configuration tools.
  • The **Preferences** menu contains tools that affect only your account, and only require normal user access. These links include:
    • **About Me** stores details about yourself that you can share with other people as an electronic business card.

    • **Appearance** customizes the appearance of your desktop, including the background picture.

    • **Assistive Technologies** lets you choose software to magnify portions of the screen or to read the contents of screens to you.

    • **Authorizations** lets you selectively permit the software on your computer to carry out certain tasks automatically and without your intervention.

    • **Bluetooth** configures Bluetooth devices to work with your computer

    • **Default Printer** specifies the printer to use by default.

    • **Desktop Effects** enables or disables special visual effects for the desktop.

    • **Display** sets the resolution and other details of your display.

    • **File Management** controls how files and folders are presented to you.

    • **Input Method** allows you to choose methods to input languages whose writing systems do not use an alphabet, such as some Indic and East Asian languages.
Chapter 3. Tour of the GNOME desktop

- **Keyboard** specifies the type of keyboard that you use with this computer.

- **Keyboard Shortcuts** sets key combinations to perform certain tasks within certain programs, or within the desktop environment more generally.

- **Main Menu** lets you add, remove, or re-order the items on the **Applications** and **System** menus, or create new menus of your own.

- **Mouse** configures the buttons and other controls on your mouse.

- **Network Connections** displays your computer's network connections and allows you to configure them.

- **Network Proxy** allows you to specify a *proxy server* for your computer.

- **PalmOS Devices** links your computer to personal digital assistants (PDAs) that use the PalmOS operating system.

- **Personal File Sharing** lets you share your documents and other files with other users of this computer or with users of other computers over a network.

- **Power Management** configures your computer to perform differently under different power settings.

- **Preferred Applications** lets you choose which applications you prefer to use for particular tasks.

- **Remote Desktop** permits you or other people to access your computer's desktop from a remote location over a network connection.

- **Screensaver** sets your screensaver.

- **Software Updates** specifies how you would like your computer to handle software updates when they become available.

- **Sound** lets you choose sounds to accompany actions or events on your computer.

- **Startup Applications** chooses applications to start automatically when you log in.

- **Windows** controls the appearance of the windows that applications appear in.

- The **Administration** menu contains tools that affect the whole system and require root access. These tools prompt for the root password when launched.

- **Add/Remove Software** lets you change the software installed on the system.

- **Authentication** allows you to control how the system verifies users who attempt to log in.

- **Bootloader** lets you choose your default boot entry and the time the boot message is displayed.

- **Date and Time** permits the system date and time to be changed.

- **Firewall** link lets you setup and configure a firewall for your computer.

- **Language** allows you to change the default language.
• **Logical Volume Management** lets you configure the LVM in a graphical setting.

• **Network** permits configuration of your network connections and devices.

• **Network Device Control** lets you monitor and control your network devices.

• **Printing** allows you to configure your printers.

• **Root Password** lets you change the root password for the system.

• **SELinux Management** allows you to change security settings that protect your computer.

• **Services** lets you decide which services will run when the system starts.

• **Software Sources** permits you to enable or disable software repositories.

• **Update System** looks for software updates at your selected software sources.

• **Users and Groups** allows you to add or remove users and groups.

• The second section provides access to the help documentation, along with information about the Fedora project, the GNOME project and information about your computer and its operating system.
  
  • **Help** is the guide for questions about GNOME.

  • **About GNOME** tells you about GNOME and the people who made it.

  • **About Fedora** is a guide containing documentation about the Fedora project.

  • **About This Computer** provides basic information about your computer and links to the process and resource monitor.

• The third section contains entries to

  • **Lock Screen** starts the screen saver or blanks the screen. It will ask for your password to restore your session to the screen.

  • **Log Out** of the current session.

  • **Shut Down** gives you options to **Hibernate**, **Restart**, or **Shut Down** your computer.

---

**Root password**

When your computer asks for your root password it means you are entering an area that changes your system's operation or performance. Beware of the messages the program generates and be sure you really want to make the changes.

---

**3.1.1.4. Application launchers**

The series of icons next to the menus provide quick access to commonly used applications. These icons are called *launchers*. 
Chapter 3. Tour of the GNOME desktop

The icon for Mozilla Firefox, a web browser.

The icon for Evolution, a mail client and personal information manager.

The icon for Tomboy, note-taking software.

To add more launchers to a panel, right-click on the panel and select Add to Panel. You can also add launchers that are in the Applications menu. Right click on the application you want to add and select Add this launcher to panel.

3.1.1.5. The notification area
The notification area displays icons that alert you to new events taking place on your computer. For example, your email program might display an icon here to indicate the arrival of new email, or your printer software might display an icon here to indicate that a document is now printing.

3.1.1.6. Volume control
The volume control allows you to quickly change the overall volume of sound on your computer. Click the icon to show a slider, and then use the mouse to drag the slider to the desired volume. If you double-click the icon, a volume control window appears in which you can separately change the volume of different sound sources.

3.1.1.7. The user switch area
If you click the current username located next to the clock, a list of available users appears. To switch to a different user account, select the username.

3.1.1.8. Clock and calendar
To access the calendar, click the clock on the right hand side of the panel. When you double-click a date, the Evolution personal information manager opens.

3.1.2. The desktop area
The default desktop area, or workspace, contains three icons:
• the Computer icon. If you double-click this icon, a window appears that contains available storage devices on the computer. These are also listed in the Places > Computer menu.

• the Home icon, which represents the location where all of the logged in user’s files, such as music, movies, and documents, are stored by default. There is a different home directory for each user, and users cannot access each other’s home directories by default.
The window list panel

- the Trash icon. Normally, when you choose to delete a file, it is not permanently removed from your system. Instead, it is sent to the trash folder, which you can access from this icon. To permanently remove a file from your system, you must empty the trash. To empty the trash, right-click the icon and select Empty Trash.

Permanently deleting files
To bypass the trash and permanently delete a file, hold down the Shift key when deleting the file.

The Fedora Live CD desktop also includes an icon for installing Fedora to your hard disk. Additional icons may appear depending on your system. For example, inserting a USB stick will cause an icon to appear for accessing the stick.

3.1.2.1. Using the desktop
Right-click on the desktop area for a menu of actions related to the desktop area. For example, the Change Desktop Background action lets you choose a different image or photograph to display on the desktop. Add program icons to your desktop by a left click on the program's icon and select Add this launcher to desktop.

3.1.3. The window list panel
This panel has four components:
- The Show Desktop button, on the left side, is used to hide all open windows, and reveal the desktop area. This function is useful when the open applications obscure an important desktop file or icon. To restore the windows, click the Show Desktop button again and all windows return to their previous location.

- Any open applications appear as button icons in the middle part of the window list panel. It shows all application windows in use on the desktop workspace, whether they are visible or hidden. A hidden window button appears with a white background. The currently selected application window button has a gray background, and is said to have focus. Usually, this is the application whose window is on top of all the others on the screen. To switch from one running application to another using the mouse, click on the desired application's button in the panel.

Use the key combination Alt+Tab to switch between open windows
Holding down the Alt key and pressing the Tab key will open a small window containing icons of all your open windows. Repeatedly pressing the Tab key cycles through the icons. Release both keys on your selection to pull it to the front.

- The Workspace Switcher is the group of squares situated on the far right. They allow you to move between workspaces. Workspaces have long been a feature of UNIX and Linux desktop environments. Each workspace provides a separate desktop where applications can be organized, and a corresponding window list panel. By default there are four workspaces available. To change this number, right-click on the workspace switcher and choose preferences.
Switching between workspaces
Use the key combination Ctrl+Alt+Left Arrow or Ctrl+Alt+Right Arrow to switch between workspaces.

Hold down the Ctrl and Alt keys and press either the Left Arrow key or Right Arrow key to cycle through the available workspaces on your system.

• The Trash icon on the right end of the window list panel works the same way as the Trash icon in the desktop area. If you delete a file, it is moved to this location. A right click on the Trash icon brings up the options to Open the folder, Empty Trash, Remove from Panel, and Lock to Panel.
Tour of the KDE desktop

This chapter introduces the KDE desktop in Fedora 12. It is easier to explain how to use the desktop throughout this guide after explaining some of the common terminology used with the KDE desktop.

4.1. The KDE desktop

If you installed Fedora 12 from the Fedora 12 KDE Live CD, KDE is the default desktop on your computer. If you installed Fedora 12 from the Fedora DVD, your default desktop is GNOME, and KDE is available as an option at the login screen. Chapter 3, Tour of the GNOME desktop describes the GNOME desktop.

The KDE desktop has two main areas:

- The desktop area
- The KDE panel

The layout and location of these items can be customized, but the term used for each of them remains the same.

The desktop area is the large space where windows are displayed. Icons for the Home folder and Trash are located in the top left corner of this area, within a tinted area that represents the contents of a folder (in this case, the Desktop folder).
Chapter 4. Tour of the KDE desktop

The KDE panel is located at the bottom, and spans the entire width of the screen. It features the **Kickoff Application Launcher**, **Device Notifier** and application launchers, displays the running applications as buttons, and gives access to the workplace switcher, calendar, and the clock.

The following sections describe the KDE desktop area and the KDE panel in further detail.

4.2. The KDE desktop area

Before any additional icons are added to it, the desktop area is fairly empty and contains only the icons for **Home** folder and **Trash**, which are contained within an area that represents the contents of the **Desktop Folder**. You can add icons to the desktop for applications or places by finding them in the **Kickoff Application Launcher** menu, right-clicking them and clicking **Add to Desktop**.

Right-clicking on the desktop presents a menu of actions related to the desktop area. For example, selecting **Appearance Settings** lets you change the desktop background and visual theme. You can also change the appearance of your desktop by clicking the **plasma toolbox** at the top right corner of the screen.

4.3. The KDE panel

By default, the KDE panel extends the full width of the bottom part of the screen and contains the following controls, called **widgets**:

- **the Kickoff Application Launcher**. In Fedora 12, this is represented by an icon of the Fedora “Infinity” logo. The **Kickoff Application Launcher** gives you access to software and storage locations on your computer, as well as allowing you to perform system-related tasks. It is described in more detail in **Section 4.3.1, “The Kickoff Application Launcher”**.

- **the Device Notifier**. This widget shows devices or media attached to or inserted into your computer, such as a USB flash drive or a CD. Holding your mouse pointed over the icon displays the devices or media. Click on this widget to see a menu that allows you to interact with the device or media.

- **the Pager**, which allows you to switch between multiple **desktops** on your computer. Multiple desktops (or **workspaces**) have long been a feature of UNIX and Linux desktop environments. Each desktop provides a separate view with different applications running in it. Four desktops are configured by default. Clicking on one of the faded workspaces will change to that workspace, or you can switch between them by holding down the **Al** key on your keyboard and pressing the **F1**, **F2**, **F3**, or **F4** key. To add more desktops, right-click on the **Pager**, then click **Pager Settings>Configure Desktops**.

- **application launchers** – icons which you can click to start particular applications. None are installed by default. You can add launchers by right-clicking the application’s icon in the **Kickoff Application Launcher**, and clicking **Add to panel**.

- **the Task Manager**, which displays buttons for any applications that are running. Clicking on one of these buttons brings that application to the foreground of your current view.
Use the key combination Alt+Tab to switch between open windows

Holding down the Alt key and pressing the Tab key will open a small window containing icons of all of your open windows. Repeatedly pressing the Tab key cycles through the icons. Release both keys on your selection to pull it to the front.

- the System Tray, which shows Klipper (a clipboard tool) and displays status notifications, such as the status of network connections or remaining battery power.

- a clock. Click on the clock to see a calendar, or right-click on it to change the way that the panel displays the time and date.

- the plasma toolbox for the panel. Clicking here allows you to change the size and proportions of the panel, and to re-arrange the order of the widgets that it displays.

4.3.1. The Kickoff Application Launcher

The Kickoff Application Launcher contains:

- Favorites – your favorite applications and places. Right click on an application or folder icon to add it to this list. The initial list consists of:
  - Web Browser – Konqueror, the default web browser installed with KDE.
  - System Settings, which allows you to personalize your computer.
  - File Manager, which allows you to browse files and folders on your computer. The default file manage installed with KDE is Dolphin

- Applications – the applications installed on your computer, sorted into the following groups:
  - Administration
  - Development
  - Education
  - Games
  - Graphics
  - Internet
  - Multimedia
  - Office
  - Settings
  - System
  - Utilities
  - Find Files/Folders
Chapter 4. Tour of the KDE desktop

- Help

- Personal Files

- **Computer** – information about your computer, and links to important places on it.
  - **System Settings**, which allows you to personalize your computer.

- **System Information**, which displays information about your computer

- **Home**, your **Home** folder, the default storage location for your documents and media files.

- **Network**, which displays information about your network connections and allows you to change network settings.

- **Root**, the folder that contains every other file and folder in your file system.

---

**Warning**

Do not move or delete items from this folder unless you are certain that you understand what you are doing. If you move or delete items within this folder, you might damage your installation of Fedora to the point where it can no longer function.

---

- **Trash**, which holds files and folders that you have deleted from your system.

- **Recently Used** – applications and documents that you used recently.

- **Leave** – options to finish working with your computer.
  - **Logout** ends your session, but leaves the computer running.

  - **Lock** leaves you logged in, but blanks the screen and prevents interaction with the computer until you type in your password.

  - **Switch User** leaves you logged in, but lets another user log in to the computer.

  - **Suspend to Disk** pauses your computer without logging out.

  - **Restart** restarts your computer.

  - **Shutdown** turns off your computer.
Tour of the Xfce desktop

This chapter introduces the Xfce 4 desktop in Fedora. It is easier to explain how to use the desktop after explaining some of the common terminology used with the Xfce 4 desktop.

5.1. The Xfce 4 desktop

One common reason for using the Xfce 4 desktop is to provide a feature-rich desktop environment for a desktop computer or a laptop with limited memory.

The Xfce desktop has three distinct areas. From top to bottom, the areas are:

- the window list panel.
- the desktop area.
- the menu panel.

The layout and location of these items can be customized, but the term used for each of them remains the same.

The window list panel is located at the top of the screen. It features the Show Desktop icon, displays the running applications as buttons, and gives access to the workplace switcher and the trash.

The desktop area is the large space between the two panels. The Filesystem, Home Directory, and Trash icons are located in the top left corner of this area.
Chapter 5. Tour of the Xfce desktop

The menu panel is located at the bottom of the screen. On the left part of the panel it contains a number of default icons that start software applications and, on the right, also provides a clock, fast user switching, volume control applet and a notification area.

The following sections discuss the Xfce 4 menu panel, desktop area, and window list panel in further detail.

5.1.1. The Xfce 4 menu panel
This panel contains a number of launchers for common software. To customize its appearance, right-click on the panel and select Properties.

• Applications contains all the programs.
• Terminal contains the console.
• Mousepad is a generic text editor.
• Thunar is a file manager program.
• Firefox is a popular web browser.
• Sound Control right mouse click allows you to mute the sound and set your preferences.
• Notification Area
• Trash
• Workspace Switcher allows you to switch to other desktops. Four are configured by default.
• Show Desktop minimizes all open windows to show a clear work area.
• Clock is a generic clock that can be modified by right clicking on it.
• Switch User/Quit is the button on which you click to log out, restart, and shutdown Xfce.

Right-clicking the clock on the right hand side of this panel provides access to a menu that allows you to:
• change the clock's display to and from a 12 and 24 hour format.
• change to or from a digital clock style.

Logging out of Xfce4 provides a way to switch the current username, this is located next to the clock.

5.1.2. The Xfce 4 desktop area
Before any additional icons are added to the desktop, the desktop area contains three icons by default:
• Filesystem – this contains all mounted volumes (or disks) on the computer; all of these are also available by clicking on the Applications menu and selecting Filesystem.
• Home – this is where all files - such as music, movies and documents - belonging to the logged-in user are stored by default. There is a different home directory for each user and users cannot by default access each others’ home directories.
• **Trash** – deleted files are moved here. Empty the **Trash** folder by right-clicking the Trash icon and clicking **Empty Trash**.

**Permanently deleting files**

To permanently delete a file, and bypass the file's move to **Trash**, hold down the **Shift** key when deleting the file.

Right-clicking on the desktop presents a menu of actions related to the desktop area. For example, clicking on **Change Desktop Background** lets you choose a different image or photograph to display on the desktop.

### 5.1.3. The Xfce 4 window list panel

The **Applications** button consists of several components:

- **Run Program...**
- **The Terminal**
- **The File Manager**
- **The Web Browser**
- **Preferences**
- **Administration**
- **Accessories**
- **Development**
- **Games**
- **Graphics**
- **Multimedia**
- **Network**
- **Office**
- **Other**
- **System**
- **Help, About, and Quit buttons.**

Open applications appear as button icons in the middle part of the window list panel.

The application window that has *focus* appears as a depressed button. Usually, this is the application whose window is on top of all others currently on the screen. To switch from one running application to another, click on the desired application’s button in the window list.
Use the key combination `Alt+Tab` to switch between open windows

Holding down the `Alt` key while you tap the `Tab` key allows you to cycle through all open applications.
Media

When you insert or connect media such as a CD, DVD, hard drive, or flash drive, to your computer, Fedora automatically recognizes it and makes it available for use. An icon is placed on your desktop and in the Places menu in GNOME. On the KDE desktop an icon is placed in the bottom panel next to the pager.

In GNOME you should unmount media before removing it from the computer. To do this, right-click on the device's icon and then select Unmount Volume or Eject, depending on what type of media you are using; during this process any remaining changes to the data on the media is written to the device, allowing safe removal without data loss. Removing media without unmounting it first could cause data to be corrupted; if this is the case, you will not be able to get your data back in the future.

There are several multi-media applications available for GNOME and KDE desktops. These applications will run in either Fedora desktop environment. To install software packages not already installed, refer to Chapter 17, Managing software. You can install applications either by using the PackageKit application or on the command line by using Yum.

6.1. ISO images

The instructions in this chapter refer to image files at various points. In this context, an image file (or disc image) is an archive file of an optical disc, in a format defined by the International Organization for Standardization (ISO). ISO image files typically have an .iso extension. The name ISO is taken from the ISO 9660 file system used with CD-ROM media, but an ISO image can also contain Universal Disk Format (UDF) file system because UDF is backward-compatible with ISO 9660. An ISO image includes all the data of files contained on the archived CD or DVD. They are stored in an uncompressed format.

In addition to data of the files it also contains all the file system metadata, including boot code, structures, and attributes. ISO images do not support multi-track, thus they cannot be used for audio CDs, VCD, and hybrid audio CDs.

6.2. Writing CDs or DVDs

Fedora includes support for writing to CDs and DVDs. This means that you can permanently burn files to CDs or DVDs for backup, file transport, or any other reason.

Required hardware

Not all optical drives (CD or DVD drives) are equipped to burn new media. An easy way to check whether that you can burn optical media is to look at the front of your disc drive. It should indicate the drive's capabilities. You can also look up the model of your drive online. An even easier way is to simply try burning a disc; chances are, if you cannot select the option for burning discs, it is not a problem with Fedora; your drive simply does not support this operation.
6.2.1. Using CD/DVD Creator to burn media in GNOME

**To open CD/DVD Creator**
To open CD/DVD Creator, select Places > CD/DVD Creator. The help manual can be accessed by pressing the F1 key or clicking Help > Contents on the top menu bar.

**To create a data disc:**
1. Drag the files and folders that you want to write to CD or DVD to the CD/DVD Creator folder.
2. Insert a writeable CD or DVD into your writer device. Doing this step first usually opens the CD/DVD Creator automatically. If not, you can configure the CD/DVD Creator to open automatically by going to System > Preferences > Hardware > Multimedia Systems Selector > and on the Audio and Video tabs select Autodetect from the drop-down menu.
3. Click the Write to Disc button, or choose File > Write to CD/DVD.

   Here you can choose write to your CD or DVD, or to a File Image. An image file (ISO) is a normal file that will be saved to your computer and you can write to a CD later.

   If you are copying regular data you can type a name for your CD or DVD in the Disc name window and select a write speed from the drop-down under Write Options. You will also see the size of your data that will be written to the disc.
4. Press the Write button to burn your data to the CD or DVD.

**To burn an image file**
To write a disc image to a CD or DVD, right-click the disc image file, then choose Open with CD/DVD Creator from the menu. When you burn a a disc image, you cannot choose the disc name or write speed.

**To make a copy of a CD or DVD**
1. Insert the disc you want to copy.
2. Choose Places > CD/DVD Creator from the top panel menu bar.
3. Right-click on the CD icon, and choose Copy Disc.
4. Follow the Write to Disc dialogue as above. If you have only one optical drive, the program will first create a file on your computer. CD/DVD Creator will eject the original disk, and ask you to change it for a blank disk on which to burn.

6.2.2. Using K3b to burn media in KDE

K3b is not installed by default from the Live CD or the DVD. If you do not have access to the Internet, you can use the Fedora DVD to install K3b. After you install K3b, using one of the methods described above, launch the program by clicking the Kickoff Application Launcher > Applications > Multimedia > K3b.

When the application opens the action buttons are displayed at the bottom of the window:

- **New Audio CD Project**
• New Data CD Project
• New Data DVD Project
• Copy a CD

To add files to your K3b project, drag the files into the project pane at the bottom of the screen. Everything in this project pane will be burned to your optical medium.

When you are ready to burn the files or folders to disk click the Burn button.

To burn an ISO image file, use the Tools > Burn DVD ISO Image. Navigate to and select the .iso image, then click the Start button.

6.2.3. Using GnomeBaker in Gnome

GnomeBaker is not installed by default from the Live CD or the DVD. If you do not have access to the Internet, you can use the Fedora DVD to install GnomeBaker. Launch the program by clicking Applications > Sound and Video > GnomeBaker.

The bottom of the GnomeBaker features three buttons:
• Data DVD, to burn files and folders to a DVD.
• Data CD, to burn files and folders to a CD.
• Audio CD, to create an audio CD.

To burn a specific file to a CD, or DVD, click the Data CD, or Data CD button, and then drag and drop the files, or entire folders, from the top pane into the bottom pane. You can also highlight the files, or folders, and click the +Add button to add them to the window.

Follow the same process to create an Audio CD, but start with the Audio CD button.

To burn an ISO image file,
1. Select Tools > Burn DVD Image or Tools > Burn CD Image from the top menu.
2. Navigate to the image file, select it, and click the OK button.
3. Click the Start button in the next window to confirm burning your disc image.

6.3. Making bootable USB media

With the liveusb-creator tool, you can set up USB media to hold a bootable copy of Fedora. This allows you to run Fedora on a computer without making any changes to the computer's hard drive, as long as the computer is capable of booting from USB media, and is set up to do so.

To create a bootable copy of Fedora on USB media, you will need:
• a USB media device with at least 800 MB of free space on it. USB media often comes in the form of flash devices sometimes called pen drives, thumb disks, or keys; or as an externally connected hard disk device. Almost all media of this type is formatted as a vfat file system. You can create bootable USB media on media formatted as ext2, ext3, or vfat.

The Fedora installation will occupy around 800 MB. Beyond this, you might want to allocate space for Fedora to store files such as documents or software installations. These documents and
programs will be available to you every time you start a computer with this USB media device, since they are stored on the device itself and not on the computer to which it is attached. This feature is a major advantage of running Fedora from Live USB media rather than from a Live CD.

**USB Image Writing is Non-destructive**

Existing data on the media is not harmed and there is no need to repartition or reformat your media. However, it is always a good idea to back up important data before performing sensitive disk operations.

**Unusual USB media**

In a few cases with oddly formatted or partitioned USB media, the image writing may fail.

- a copy of the Fedora Live CD or Fedora KDE Live CD, or a connection to the Internet. The liveusb-creator tool copies the files from a Fedora Live CD or Fedora KDE Live CD to create bootable USB media. If you do not have a Fedora Live CD or Fedora KDE Live CD, liveusb-creator can download a CD image from the Internet. However, because this CD image is a very large file, you might find this approach impractical if you do not have a broadband Internet connection.

- the liveusb-creator tool, for Fedora or Microsoft Windows. Instructions for obtaining this tool appear in the following sections specific to each operating system.

### 6.3.1. USB image creation in Windows


2. Follow the instructions given at the site and in the liveusb-creator program to create the bootable USB media.

### 6.3.2. USB image creation in Fedora

You can install liveusb-creator by clicking on System > Administration > Add/Remove Software, then searching for liveusb-creator and installing it.

You can also install the application from the command line with the following command:

```
# yum install liveusb-creator
```

To open liveusb-creator click on Applications > System Tools > liveusb-creator. To create live USB media,

1. enter your password.

2. choose whether to Use existing Live CD and specify its location on your comptuer, or to Download Fedora and select a file from the drop-down menu.

3. select your Target Device for your Fedora installation, such as a USB memory stick.
4. select how much **Persistent Storage** you want. This is space that Fedora can use to hold documents and other files.

After you have made all of your choices just press the **Create Live USB** button to start the process.

Visit the [liveusb-creator web page](http://fedorahosted.org/liveusb-creator) for more information.

Another option to create a USB Image is:

---

**Advanced usage**

This content is written for the more advanced user. It assumes that you are comfortable with the command line and have a relatively good knowledge of Linux terminology. It is probably not necessary to using Fedora as a desktop user, but can help a desktop user expand his or her knowledge base and face more complicated troubleshooting issues.

1. Install the "livecd-tools package" on your system with the following command:

   ```bash
   su -c 'yum -y install livecd-tools'
   ```

2. Plug in your USB media.

3. Find the device name for your USB media. If the media has a volume name, look up the name in `/dev/disk/by-label` or use `findfs`

   ```bash
   su -c 'findfs LABEL="MyLabel"'
   ```

   If the media does not have a volume name, or you do not know it, consult the `/var/log/messages` log for details:

   ```bash
   su -c 'less /var/log/messages'
   ```

4. Use the `livecd-iso-to-disk` command to write the ISO image to the media:

   ```bash
   su -c 'livecd-iso-to-disk the_image.iso /dev/sdX1'
   ```

   Replace `sdX1` with the device name for the partition on the USB media. Most flash drives and external hard disks use only one partition. If you have changed this behavior or have oddly partitioned media, you may need to consult other sources of help.

---

1. [http://fedorahosted.org/liveusb-creator](http://fedorahosted.org/liveusb-creator)
Connecting to the Internet

Fedora includes a graphical tool to help configure various connections and network interfaces. **KDE** is included by default and allows easy management of configured connections.

### 7.1. GNOME

To launch the Network Configuration Tool in GNOME, navigate to the **System > Administration > Network** menu entry. When working as a regular user the application prompts for the root password.

### 7.2. KDE

To launch the Network Configuration Tool in KDE, navigate to the **KMenu > Applications > System > Network** menu entry. When working as a regular user the application prompts for the root password.

### 7.3. Configuring PPPoE

PPPoE connections are primarily used for xDSL connections. PPPoE stands for Point-to-Point Protocol over Ethernet.

In the main screen, click the **New** Button and then choose **XDSL Configuration** from the left hand column, clicking the **Next** button to proceed.

In the following screen, enter the name of the xDSL provider, and the username and password belonging to this account. When more than one Ethernet device is present on the system, ensure the correct device is selected from the drop down menu labeled **Ethernet device**. Click **Next** to proceed.

To configure this network connection to start when the system boots, click the appropriate entry in the main dialog, and then click the **Edit** button. Ensure that the **Active device when computer starts** box is ticked. To learn how to manually activate this connection refer to **Section 7.6, “NetworkManager”**.

### 7.4. DHCP connection

**DHCP is enabled by default**

Fedora configures network interfaces to use DHCP by default. You will only need these instructions if DHCP was deactivated at some point.

DHCP connections are common when using cable modems, Local Area Networks (LANs), and most broadband Internet connections for home and small business use.

To enable DHCP for a particular network interface, launch **Network Manager**, select the appropriate entry for the interface and click **Edit**. Ensure that the **Automatically obtain IP address settings with** is selected and set to DHCP.

### 7.5. Static IP address

To configure a network interface for a static IP address, click on the network interface in the main dialog, and then click the **Edit** button. Next ensure that **Static IP addresses** is marked, filling in the appropriate details in the **Manual IP Address** section.
Chapter 7. Connecting to the Internet

For a static IP address, it is also necessary to fill in the details under the **DNS** tab of the main interface.

### 7.6. NetworkManager

**NetworkManager** is not enabled by default in Fedora, it is installed by default however. Enabling **NetworkManager** is a simple process of going to **System > Administration > Services** and checking **Network Manager** and **Network Manager Dispatcher**.

**Note**

Make sure to save the modifications otherwise the changes will not be written to file. To start them straight away you will need to highlight **Network Manager** and **Network Manager Dispatcher** and click the **Start** button.

**NetworkManager** simplifies the process of connecting your laptop or desktop to the network. When you have enabled the programs you should see the **nm-applet** icon.

When it has been enabled you can right click on the icon and enable wireless or wired networks. Enabling both does not affect how **NetworkManager** operates.

If you have a wireless network and it is supported by Fedora left clicking on the icon and selecting **Connect to other network** and putting the details of your connection will cause **NetworkManager** to use that information to connect to the network.

### 7.7. Wireless

Fedora includes some wireless firmware and methods to install closed-source firmware. **NetworkManager** automatically functions with the drivers that you installed in Fedora.

The following wireless drivers are available in the Fedora repositories:

<table>
<thead>
<tr>
<th>Firmware name</th>
<th>Firmware description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ipw2100-firmware</td>
<td>Intel IPW2100</td>
</tr>
<tr>
<td>iwl3945-firmware</td>
<td>Intel IPW3945</td>
</tr>
<tr>
<td>iwl4965-firmware</td>
<td>Intel IPW4965</td>
</tr>
<tr>
<td>b43</td>
<td>Broadcom PCI/Cardbus</td>
</tr>
<tr>
<td>b43legacy</td>
<td>Broadcom PCI/Cardbus</td>
</tr>
<tr>
<td>adm8211</td>
<td>Admtek PCI/Cardbus</td>
</tr>
<tr>
<td>p54</td>
<td>Prism54 USB and PCI/Cardbus</td>
</tr>
<tr>
<td>zd1211rw</td>
<td>Zydas USB</td>
</tr>
<tr>
<td>rtl8180</td>
<td>Realtek PCI/Cardbus</td>
</tr>
<tr>
<td>rtl8187</td>
<td>Realtek USB</td>
</tr>
<tr>
<td>rt2x00</td>
<td>Ralink USB and PCI/Cardbus</td>
</tr>
<tr>
<td>ath5k</td>
<td>Atheros PCI/Cardbus</td>
</tr>
<tr>
<td>ipw2200</td>
<td>Intel IPW2200</td>
</tr>
<tr>
<td>Firmware name</td>
<td>Firmware description</td>
</tr>
<tr>
<td>---------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>orinoco/hostap</td>
<td>Prism2</td>
</tr>
</tbody>
</table>

If you need any of these drivers, install the software using **PackageKit** by going to **Applications > Add/Remove Software** or use the command line. For example, to install the iwl3945 firmware:

```
su -c 'yum install iwl3945'
```

You can search for software by going to the search tab in **PackageKit** or by using the command line. For example, to search for the orinoco software:

```
su -c 'yum search orinoco'
```

**Note**

A current bug with some of the firmware is that the wireless light is not enabled, this does not mean the wireless card is turned off.

### 7.8. Remote desktop

Fedora has remote desktop as part of the default install.

- In Gnome, select **System > Preferences > Remote Desktop**
- In KDE, select **KMenu > Applications > Settings > Desktop Sharing**

Enabling 'Desktop Sharing is as simple as ticking the **Allow other users to view your desktop**. If you would like other people to control your desktop you can tick the appropriate setting.
Accessing the Web

Fedora uses **Mozilla Firefox** by default in Gnome and **Konqueror** in KDE to access the *World Wide Web* (Web). There are many other browsers available to suit different users’ needs. **Dillo** is an example of a lightweight browser, and browsers such as **lynx**, **w3m**, and **elinks** are console based.

Besides being standards-compliant web browsers, **Firefox** and **Konqueror** have many features beyond basic web browsing. This chapter explains how to use some of the more popular features, and provides links to further information.

The Internet can also be used to transfer files. This chapter covers different methods of doing this using graphical applications as well as the command line. If you wish to transfer files using email, then you should probably read Chapter 9, *Communications* instead. This is often the best choice for smaller files such as pictures and documents.

## 8.1. Browsing web pages

**Firefox** and **Konqueror** are the suggested web browsers for most users. If you require a more lightweight browser (especially if you are using a slower system), you may want to try **Dillo**. If you are using the command line, then you may want to use **lynx**, **w3m**, or **elinks**. None of these programs are installed in Fedora by default, but can be installed using the instructions in Chapter 17, *Managing software*.

### 8.1.1. Using Firefox

To start **Firefox** in GNOME, select **Applications > Internet > Firefox Web Browser** or use the menu panel icon. To start **Firefox** in KDE, select **KMenu > Applications > Internet > Firefox Web Browser**.

**Firefox** has many more features than discussed here; you can find more information on **Firefox** at the Mozilla Firefox website: [http://www.mozilla.org/support/firefox/](http://www.mozilla.org/support/firefox/).

### 8.1.1.1. Navigating the web

Fedora starts **Firefox** with a default home page that has links to useful Fedora-related sites. Navigate to other web pages by typing the web address – also called the *universal resource locator*, or URL – into the long navigation bar across the top of the **Firefox** screen, replacing **http://start.fedoraproject.org**.

If you do not know the URL, enter a keyword (or words) into the search bar to the right of the navigation bar, then press the **Enter** key. The search engine used to perform your search can be changed by left-clicking the logo in the search box. You will be presented with a list of options including **Google**, **Yahoo**, **eBay**, **Amazon**, and **Creative Commons**.

Like other web browsers, **Firefox** makes it possible to save a web page for future reference by adding it to a list of **bookmarks**. Use the key combination **Ctrl+D** to bookmark a page you are viewing. To manage bookmarks, use the **Bookmark** menu from the top of the **Firefox** window. You can also create a live bookmark (**a feed**) that automatically checks for updates from a page with an **RSS** or **Atom** feed. If a feed is available for a particular web page, there will be an orange icon at the right hand edge of the address bar while you are visiting that page. Left click the feed icon and a preview of the feed is displayed. Select the method you would like to use to subscribe to the feed.
Use your favorite feed reader

Firefox can use a number of popular web-based options for subscribing to feeds, such as Bloglines, My Yahoo, and Google Reader, as well as Firefox's own live bookmarks. Another option is to use a desktop feed reader you have installed, such as Liferea.

8.1.1.2. Tabs

Open a new tab with Ctrl+T. A blank page is presented and a new bar is available under the navigation bar showing all open tabs; to switch between them left-click the desired tab. To close a tab you can either right click to access the context menu or press the red “X” on the tab.

Navigating a large number of open tabs can be difficult. To make it easier, use the arrow icon on the right hand side of the tabs toolbar. Click this to reveal a list of all open tabs that you can switch to by clicking on the relevant item.

8.1.1.3. Extensions

Firefox is designed to be moderately fast and lightweight. As a result, some functionality found in other browsers may not be available by default. To solve this problem the Firefox team made the browser extensible, so it is easy to create and integrate extensions that add new functionality to the browser.

To manage and install extensions, plug-ins, and themes, select the Tools > Add-ons menu entry. New extensions are found by visiting the Firefox add-on site at https://addons.mozilla.org/en-US/firefox/. To install an extension from this site follow the Install link, and when prompted click Install Now.

Themes, plugins and search engines

Firefox can also be extended by adding new search engines to the search box, installing new themes to customize the look, and installing new plugins allowing the use of Java and other web technologies. All of these can be found at Mozilla's Firefox add-ons site.

8.1.2. Using Konqueror

To start Konqueror in KDE, select KMenu > Applications > Internet > Konqueror. To start Konqueror in GNOME, select Applications > Internet > Konqueror.

Konqueror on the GNOME and Xfce desktops

Konqueror is installed by default with the KDE desktop, but not the GNOME or Xfce desktops. If you want to use Konqueror on the GNOME or Xfce desktops, you will need to install it first. Refer to Chapter 17, Managing software for instructions on adding new software to your system.
### 8.2. Transferring files

**Advanced Usage**

This content is written for the more advanced user. It assumes that you are comfortable with the command line and have a relatively good knowledge of Linux terminology. It is probably not necessary to using Fedora as a desktop user, but can help a desktop user expand his or her knowledge base and face more complicated troubleshooting issues.

Fedora includes several programs for transferring files between different computers on the same network (or on the Internet). One of the most common methods is called the File Transfer Protocol (FTP). There are several graphical programs available to use FTP, including FileZilla and gFTP. You can also use the command line utilities `ftp`, `lftp`, and `sftp`.

**FTP is insecure**

If you are transferring files over a public network (such as the Internet), you may not want to use FTP. FTP transfers can be easily intercepted, and FTP data is not encrypted. For more security, use SFTP, which encrypts your data over SSH.

#### 8.2.1. Using FileZilla

FileZilla is an application that allows you to transfer files over FTP using a simple graphical interface. Like many FTP applications, it has two important panes: a file browser for your local machine, and a file browser for the remote machine. This way, you can browse to a file on a remote server and drag-and-drop it to a folder on your local host.

To install FileZilla, refer to Chapter 17, Managing software. You can install FileZilla by either using PackageKit or on the command line using Yum. More information about FileZilla is available at [http://filezilla-project.org/](http://filezilla-project.org/).

**FTP with web browsers**

If you don’t need to send a file, but only retrieve it, you can use Firefox, Konqueror, and many other web browsers. Just browse to the ftp server in the address bar, and make sure to specify that you want to use FTP. Generically, you would type `ftp://ftp.server.com`, where `ftp.server.com` is the address of the FTP server.

#### 8.2.1.1. Connecting to a server

To connect to an FTP server in FileZilla, you must add the server to your Site Manager. You can open the Site Manager dialog in three ways:

- Click on File > Site Manager
- Click the first icon to the left on the tool bar
- Use the keyboard shortcut `Ctrl+S`

When the Site Manager dialog is open, click the New Site button. The first thing FileZilla will want to know is the name that you want to use to refer to this server. There will be a text entry box under
My Sites on the left side of the dialog. Here, type whatever name you want to use to refer to the new server. This name doesn't have any technical implications; choose something convenient for you.

On the right side of the dialog box, you will need to enter the following information:

Host
This is the address of the server. If the server has a URL (such as ftp.server.com), you can type it in here. Otherwise, you'll need to type in the IP address. An IP address is of the form A.B.C.D, where A, B, C, and D are integer values between 0 and 255 (inclusive). The server you are connecting to should provide you with this information.

Port
You only need to fill in a value for this field if the server does not use the default (port 21 for FTP, port 22 for SFTP).

Servertype
Here, you can choose FTP, SFTP, FTPS, or FTPES. Only FTP and SFTP will be discussed here.

Logontype
This field allows you to choose how you will authenticate with the server. This information should be provided by the server you are trying to connect to.

User, Password, Account
These fields will only be active if you use certain Logontypes. If they are active, you should use them for your username, password, and account on the remote server.

Comments
This field has no technical relevance. It may be convenient for you to make a note of something about the server here.

When you have filled out the fields, click OK to close the Site Manager or Connect to close the Site Manager and then connect to the FTP server immediately. Clicking Cancel will ignore any changes you made to the Site Manager and close the dialog.

To connect to a server later on that you have already added to Site Manager, simply open the Site Manager, click on the server you want to connect to, and click Connect.

8.2.1.2. Transferring files
If you connect to a server successfully, you should see some status messages appear in the top pane indicating that you have connected to the remote server. The right-hand file browser pane should also display the contents of the remote directory you connected to.

To transfer a file, simply drag-and-drop it from one file browser into the folder of the other file browser. You can also select a file in one pane, a folder in the other, and click the appropriate arrow button to transfer the file.

8.2.2. FTP on the command line
To use the ftp program, type ftp at a console prompt. You should be put into an FTP shell that looks like this:

```
ftp>
```
To get a list of commands, type `help`. To get a simple description of any command, type `help command`. This guide will only cover a fraction of these commands; read about the rest in the `ftp` man page.

### 8.2.2.1. Connecting to an FTP server

To log in to an ftp server, use the `open` command. The syntax is `open ftp.server.com port`

Where `ftp.server.com` is the FTP server you wish to connect to. It is not necessary to specify a port with this command unless you are connecting to a non-default port. The default port for FTP is port 21. Alternatively, you can connect to an FTP server as you start the `ftp` program. To do this, use the syntax `ftp ftp.server.com portftp.server.com port` Where the `port` option is, again, optional.

### 8.2.2.2. Managing files

Often, FTP is used to retrieve a file from a public server. You can obtain this file from the server by using the `get file` command, where `file` is the name or path of the file you want to retrieve. To view all the files in the directory you have connected to, you can use the `ls` command. You can also use `pwd` to determine which directory you are currently in, and then `cd` to change your directory.

To send a file to the server, type `put file`, where `file` is the name or path of the file you wish to send. To view all the files in your local directory (not the remote FTP server), type `lcd`. You can also type `lcd directory` to change to a new directory on your local machine.

### 8.2.2.3. SFTP on the command line

Secure FTP, or SFTP, is an encrypted version of FTP. It connects over to the remote server through a secure socket layer, like SSH. This means that it is a much more secure solution than traditional FTP. Use the command `sftp` to start the client. The syntax is nearly identical to the syntax for FTP.

### 8.2.2.4. Secure copy (SCP)

Another option for transferring files between two computer with SSH is using the command `scp`. This attempts to use the same syntax as the tradition copy command (`cp`), but differs in that you can specify remote servers. For example, to send a file to a remote server, type

```
$ scp localFile user@server:/destination/directory/
```

You can similarly fetch a file:

```
$ scp user@server:/path/to/wantedfile destinationFile
```

Or even between two remote servers:

```
$ scp user1@server1:/path/to/source user2@server2:/path/to/destination
```

In every case that you access a remote server, you will be prompted for your credentials (such as a username and password).
Communications

Fedora can be used to send electronic mail and communicate in real time with people around the world through instant messaging and chat rooms. In GNOME, **Evolution** is used to send electronic mail (email) by default. **Evolution** can also be used as a personal information manager, or **PIM**. You can maintain a calendar, manage a list of tasks, and keep an address book of contacts.

In KDE, **Kmail** is used to send email by default. While **Kmail** does not include a calendar, a calendar application called **KOrganizer** is included as part of the **KDE PIM** suite. There is also an application called **Kontact** which groups **KMail**, **Korganizer** and other KDE PIM tools into a single interface (comparable with GNOME’s **Evolution**).

**Thunderbird** is an open-source mail client maintained by Mozilla. It is very extensible, with an online plug-in library akin to **Mozilla Firefox**. **Claws Mail** is a more lightweight email client and news reader, which is also extensible via additional plug-ins. **Claws Mail** only supports plaintext emails by default.

**Pidgin** and **Kopete** are both Instant Messaging (IM) programs that allow you to talk to people in real-time using chat networks like AIM, Yahoo! Messenger, or Gmail chat. **XChat** is Fedora’s default graphical IRC client and **Konversation** is the default IRC client for KDE. **ChatZilla** is an IRC client installed and used via the **FireFox** web browser. These clients can all connect to IRC servers which provide chat rooms for people around the world to discuss specific topics.

9.1. Evolution

**Evolution** is a full featured email program. In addition to email, Evolution features a personal information manager (PIM), a calendar, task manager and an address book for your contacts. More documentation for **Evolution** is available at: [http://www.gnome.org/projects/evolution/documentation.shtml](http://www.gnome.org/projects/evolution/documentation.shtml)

9.1.1. Configuring Evolution

To configure an email account:

1. Start **Evolution**
   - in GNOME, click **Applications > Office > Evolution** on the top menu bar.
   - in KDE, click **Kickoff Application Launcher > Applications > Internet > Email** menu entry.

2. Running the software for the first time displays the **Evolution Setup Assistant** wizard. Answer these questions using information provided by your ISP or email provider.
   - The **Identity screen** relates to personal information about the account, including **Name**, **Organization**, and **Address**. There is also a **Reply-To** field, which will allow you to specify that recipients of mail from this account can reply to a different email address than the one that sent the email.
   - The **Receiving Email** and **Sending Email** screens both require information from the e-mail provider.

To add a new account in the future, or to modify an existing account, launch the preferences dialog from the **Edit > Preferences** menu. In the dialog that appears, press the **Add** button to launch the **Evolution Account Assistant** again.
9.1.2. Using Evolution

**Evolution** allows you to create, store and send email by clicking the appropriate buttons located on the menu.

- **Send/Receive**
  - Prompts **Evolution** to send and receive all email.

- **New**
  - Opens a new email message dialog box.

- **Reply**
  - Replies to the person who has sent you an email.

- **Reply to All**
  - Replies to everyone who was included in the email that you have received.

- **Forward**
  - Forwards the email message to another person.

- **Print**
  - Prints the email.

- **Delete**
  - Deletes the message.

- **Junk**
  - Marks the email as junk.

- **Not Junk**
  - If you accidentally set the email as Junk, pushing this button removes the Junk tag.

- **Cancel**
  - Cancels whatever **Evolution** was doing.

- **Previous**
  - Moves to the previous email in your folder.

- **Next**
  - Moves to the next email in your folder.

9.2. Thunderbird


9.2.1. Configuring Thunderbird

To configure your email account you will need the email information provided by your ISP or email provider.

1. Open **Thunderbird**:  

Moving your Thunderbird profile data from Windows to Fedora

1. In GNOME, click Applications > Internet > Thunderbird on the top menu bar.

2. The first time you start Thunderbird the Account Wizard opens to guide you through the setup of your account. If the Account Wizard does not open, select File > Create New Account in the main window to open the wizard.

3. Select Email account and press Next.

4. Fill in your name and email address, and click Next.

5. Now choose POP or IMAP and type in the names of the Incoming and Outgoing servers and select Next. This information should have been provided by your email service.

6. In the next window, fill in your username for your email provider. Normally your Incoming and Outgoing username are the same. Press Next.

7. Type in whatever you want for your Account Name and click Next. This will be used to represent the new account in Thunderbird.

8. Check the summary in this window. If something needs to be changed press the Back button; otherwise click Finish. Now Thunderbird connects to the server to download your email messages.

9. If the download fails, your email account may require secure connections. In this case, select Edit > Account Settings > Server Settings and select your secure setting. Often the setting is SSL, but this information should be provided by your email service.

9.2.2. Moving your Thunderbird profile data from Windows to Fedora

The Thunderbird data profile folder contains your email messages, addresses, and program settings. To move your profile data from Windows to Fedora requires that the data folder be copied to a CD/DVD, memory stick, or other mobile media. If you have set up multiple accounts in Thunderbird, they can be moved as well, one at a time, following these steps:

1. Find your profile data folder
   - In Windows 2000 or Windows XP, click Start > My Computer > Local Disk (C:) > Documents and Settings > YourUserName > Application Data > Thunderbird > Profiles. The profile data folder looks like xxxxx.default, where xxxxx is a sequence of random numbers and letters.

   **If you cannot find the Application Data folder**
   If you cannot find the Application Data folder, go to the top menu and select: Tools > Folder Options > View and check the box Show Hidden Files and Folders.

   If you still cannot find the folder, click: Start > Run, type %AppData% and press Enter.
• In Windows Vista, click **Start > Computer > C: > Users > YourUserName > AppData > Roaming > Thunderbird > Profiles**. The profile data folder looks like `xxxxx.default`, where `xxxxx` is a sequence of random numbers and letters.

If you cannot find the Application Data folder
If you cannot find the Application Data folder, click **Start > Control Panel > Classic View > Folder Options > View** and check the box **Show Hidden Files and Folders**.

If you still cannot find the folder, click: **Start**, type `%AppData%` into the **Start Search** box and press **Enter**.

Copy your profile data folder to removable media
Right click on the profile data folder and select: **Send To > CD/DVD or memory stick**. Then press the **Back** button until you arrive at **My Computer** and check to make sure the folder was saved to the media.

3. Copy your profile data folder to Fedora

Set up your email account or email accounts first
To move the folder to Fedora you need to have your email account, or accounts, set up in **Thunderbird** on your Fedora installation. When you set up an email account, **Thunderbird** creates the profile data folder for that account. If this folder does not yet exist, you do not yet have a destination for the copy of the folder on your removable media. Refer to **Section 9.2.1, “Configuring Thunderbird”**.

a. Open the Thunderbird profile data folder in Fedora:
   • In GNOME, click **Places > Home Folder > .thunderbird > xxxxxx.default**, where `xxxxx` is a random sequence of letters and numbers. Note that this sequence will be different from the sequence that you saw in your **Thunderbird** installation on Windows.

If you cannot find the .thunderbird folder
If your Fedora installation originally had an early version of **Thunderbird** installed on it, your profile data folder might be under `.mozilla-thunderbird` instead of `.thunderbird`.

If you cannot find either a `.thunderbird` or `.mozilla-thunderbird` folder within your **Home Folder**, press **Ctrl+H** to display **Hidden Files**.

• In KDE, click **Kickoff Application Launcher > Computer > Home > .thunderbird > xxxxxx.default**, where `xxxxx` is a random sequence of letters and numbers. Note that this sequence will be different from the sequence that you saw in your **Thunderbird** installation on Windows.
b. In the xxxxxx.default folder, press Ctrl+A to select all files and folders, then press Delete to move them to the Trash. The folder should now be empty.

c. Plug in the media containing the folder you copied from Windows.

d. Open the media and click on the xxxxxx.default folder saved from Windows to open it. Click Edit > Select All > Edit > Copy

e. Move back to the empty xxxxxx.default window and click Edit > Paste.

f. Start Thunderbird and verify that you can see the email messages, addresses, and settings from your Thunderbird installation on Windows.

9.2.3. Using Thunderbird

The first time you press the Get mail button you are asked for your password. Type in your password and press Enter or click the Ok button. You might want to check the box Use Password Manager to remember this password. If you do, Thunderbird will automatically check your email without asking for your password in the future. Before choosing this option, remember that there is always some risk associated with storing a password. If your password and setup was correct, Thunderbird will now download your email messages from the server.

Thunderbird allows you to create, store and send email by clicking the appropriate buttons located on the menu at the top of the screen:

- **Get Mail**
  Prompts Thunderbird to send and receive all email.

- **Write**
  Opens a new email message dialog box.

- **Address Book**
  Opens the email addresses you have on file.

- **Reply**
  Replies to the person who has sent you an email.

- **Reply All**
  Replies to everyone who was included in the email that you have received.

- **Forward**
  Forwards the email message to another person.
9.3. Claws Mail

**Claws Mail** is an email client and news reader built to be lightweight and easy to operate. Claws Mail features mostly basic functionality, but plugins can be used to add many of the features found in **Evolution** and **Microsoft Office Outlook**. To install **Claws Mail**, refer to Chapter 17, Managing software. You can install Claws Mail by either using **PackageKit** or on the command line by using **Yum**. More information about **Claws Mail** is available at: http://www.claws-mail.org/.

9.3.1. Configuring Claws Mail

To configure your email account you will need the email information provided by your internet service or email provider:

1. Open **Claws Mail**:
   - in GNOME, click on Applications > Internet > Claws Mail.
   - in KDE, click the Kickoff Application Launcher > Applications > Internet > Email menu entry for **Claws Mail**.

2. The first time you start **Claws Mail** the **Claws Mail Wizard** appears and will guide you through the set up of your account:

3. The first page asks you to fill in your name, (sometimes it is guessed from the operating system) and your email address.

4. On the next page enter details of how to retrieve your mail:
   POP3
   - Enter the **server address**, **username**, and **password**. If you don't enter your **password** here you will be prompted for it each time it is needed.
   IMAP
   - Enter the **server address**, **username**, **password**, and **IMAP server directory**. The **password** is optional, if you don't provide it here you will be prompted for it each time it is needed. The **IMAP server directory** is also optional, often it is not needed and can be left empty.
Local mbox file

Enter the location of your local mailbox spool file. Values such as `/var/mail/username` or `/var/spool/mail/username` are common, `username` is your system login.

5. On the next page enter the address of your SMTP (Outgoing) server. You may not need to authenticate when sending mail.

6. If you chose either POP3 or Local mbox file, the next page will the show the default where it will save your mail.

7. You may get a Security page, where you can choose SSL encryption to send and receive your emails. If you're unsure leave them unselected.

8. Click on the Save button to finish the configuration.

9.3.2. Using Claws Mail

Claws Mail allows you to create, store and send email by clicking the appropriate buttons located on the menu. Retrieving your email can be done from the toolbar button named Get mail or from the Receive submenu of the Message menu.

Get Mail

Allows Claws Mail to receive all email.

Compose

Opens a new email message dialog box. Press Tab to autocomplete the To: email address from the address book.

Reply

Replies to the person who has sent you an email.

Reply to All

Replies to everyone who was included in the email that you have received.

Sender

Replies to the person who sent the email.

Forward

Forwards the email message to another person.

Trash

Moves the message to the Trash folder.

Spam

Tells the program to learn the email as spam (junk mail), also has option to mark it as ham (not junk mail). Moves the message to the Trash folder.

Next

Moves to the next email in your folder.
9.4. Kmail

Kmail is the standard email client used in KDE. It is installed by default from the Fedora KDE Live CD and is also included in the DVD. To start Kmail in KDE, click the Kmenu > Applications > Internet > Email menu entry for Kmail, or in GNOME, click Applications > Internet > Kmail in GNOME.

9.4.1. Configuring Kmail

Running the software for the first time displays the main Kmail page with links to help locations. To add a new account in the future, or to modify an existing account, click Settings > Configure Kmail. In the dialog that appears, select Accounts then press the Add button to launch the Kmail Account Assistant again.

To configure your account, you will need your email information from your internet service or email provider.

1. Click Settings > Configure Kmail
2. Click Accounts > Add. A dialog will ask you for the type of account you wish to configure.
3. When you select the appropriate account type, a dialog will show you the different settings available for your account. Add your personal email configuration information to Account Name, Login, Password, Host. The other default settings can be left alone.

9.4.2. Using Kmail

Kmail allows you to create, store and send email by clicking the appropriate buttons located on the menu:

New Message
- Opens a new Compose email dialog box.

Save as
- Saves the email.

Print
- Prints the message.

Check Mail in
- Downloads emails from the remote server.

Reply
- Replies to the selected email.

Forward
- Forwards the email message to another person.

Previous
- Moves to the previous unread email in your folder.

Next
- Moves to the next unread email in your folder.

Trash
- Deletes the email.
Find Message
Searches for a specific email.

Create Task
Creates a new task in KOrganizer.

Additional Options
KMail has additional options, marked with a green, downward-pointing arrow. Clicking this button and holding it down for a few seconds will show additional options. The description of these features is beyond the scope of this guide.

9.5. Pidgin
Pidgin is an instant messaging (IM) client that can access Gmail, MSN, AOL, Yahoo!, Jabber, and other IM and chat networks. For further information please refer to: http://www.pidgin.im

9.5.1. Configuring Pidgin
To start and configure Pidgin, select Applications > Internet > Internet Messenger from the menu panel in GNOME or the Kickoff Application Launcher > Applications > Internet > Instant Messenger menu entry for Pidgin in KDE.

Starting Pidgin for the first time goes directly into the Accounts dialog. To configure a new account follow these steps:

1. Click on the Add button to bring up the Add Account dialog.

2. In the Add Account window, under Login Options, click on the right side of the Protocol dropdown menu to show the available protocols and select the network appropriate for the account being created.

3. Enter details for the selected account, including Screen name, Password, and Alias. Select Remember password if desired. Click on the Save button to add the account to the account list.

4. Once the account is added, the Accounts window displays the new account.

5. New accounts can be added in the future by navigating to the Accounts > Add/Edit menu entry in the main Pidgin window.

9.5.2. Using Pidgin
Select one of the enabled accounts to see the Buddy List window. These menus allow you to add additional IM contacts.

All 16 supported protocols are available at the same time within Pidgin. If you have setup several accounts in Pidgin, such as Yahoo, Google Talk, and AIM accounts, then all of your contacts for each of these accounts will be available to chat with at the same time, in the same contact list.

For more information see: http://developer.pidgin.im/wiki/Using%20Pidgin
Not all features supported

Pidgin does not support some features of the included protocols. Pidgin is useful for chatting via text across 16 different IM protocols, but not all the features in each IM system are supported. For example, video is not supported at this time.

Fedora does not register all accounts

Many IM networks require you to create an account before you can use them. In many of these cases, you cannot create the account in Pidgin and will normally need to visit the website of the network to create an account. For example, you cannot use Pidgin to create a Yahoo Instant Messenger account. Instead, you much first visit http://messenger.yahoo.com to set up the account, then access it using Pidgin.

9.6. Kopete

Kopete is the Instant Messenger installed in KDE by default. To start the program in KDE, click the Kickoff Application Launcher > Applications > Internet > Instant Messenger menu entry for Kopete. In GNOME, click Kopete can be found in Applications > Internet > Kopete. For further documentation on Kopete, refer to: http://kopete.kde.org/

9.6.1. Configuring Kopete

Starting Kopete for the first time takes you directly to the creating accounts dialog. To configure a new account:

1. Choose a messaging service from the list.
2. In the Account Information window, enter your details that you are using to connect to the services.
3. Make sure to fill out the details on the other tabs.
4. Once the account is added, click Next and choose the option to connect to the service and then click Finish.

You can add new accounts in the future by navigating to the Settings > Configure menu entry in the main Kopete window, then clicking the Accounts button.

Kopete comes with a wide range of messaging services such as:

• AIM
• GroupWise
• ICQ
• IRC
• Jabber
• Meanwhile
• MSN Messenger
• Testbed
• WinPopup
• Yahoo

You can add accounts for these services to Kopete using the steps above.

9.7. XChat

XChat is an IRC chat program. It allows you to join multiple IRC channels (chat rooms) at the same time, talk publicly, private one-on-one conversations and is capable of transferring files. More information is available at http://xchat.org/.

9.7.1. Configuring XChat

1. When you open XChat the XChat: Network List window appears. Fill in your choices for your Nick name, username and realname. Your username can be anything you like.

2. Now choose a network to join from the Networks window. Select the one you want by clicking it.

3. Select Edit which opens another window listing the network you selected. For now make sure the box Use global user information is checked. Go down to the Favorite Channels field and type in the channel you want to join. You can also click on the small button to the right of the field which will bring up a window where you can Add, Remove and Edit your channels. Most networks require # placed before the name of the channel. For example, #fedora-userguide.

4. Click the Close button.

5. Select Connect and you are connected to your channel.

6. You configure your preferences for XChat while attached to the network. On the top menu bar select Settings > Preferences and choose your text, background and sound preferences.

9.7.2. Using XChat

On the top menu bar select Applications > Internet > XChat.

Click the Connect button and you are attached to the networks and channels that you selected above.

9.8. Konversation

Konversation is located on the KDE Desktop. You can find details at http://konversation.kde.org/.

9.8.1. Configuring Konversation

To configure Konversation select:

1. Kickoff Application Launcher > Applications > Internet > IRC Client.

2. The Servers List window pops up and has a default network listed. Select New or click on the default network then select Edit.
   a. Type in your chosen network in the Network Name: field.
   b. Under Identity click Edit and add your user names.
c. Check the box **Connect Application at Start-up** to attach automatically when you open **Konversation**

3. In the **Auto Join Channels** window:
   a. Click on the default channel listed then **Edit** or just click the **Add** button to add your choice.
   b. Type in your desired channels, and passwords if needed, then click the **Ok** button.

4. You are returned to the **Edit Network** window. Select the **Ok** button. Now click the **Connect** button at the bottom right in the **Servers List** window to attach to the network and your channels.

### 9.8.2. Using Konversation

Choose **Kickoff Application Launcher > Applications > Internet > IRC Client.**

Konversation will automatically attach to your networks and channels.

### 9.9. ChatZilla

ChatZilla is an IRC chat program from Mozilla. It is easy to use and is a highly extensible IRC client. It has all the usual features including a built-in list of standard networks, easy searching and sorting of available channels, logging, DCC chat and file transfers. For more information go to [http://chatzilla.hacksrus.com/faq/](http://chatzilla.hacksrus.com/faq/).

#### 9.9.1. Installing ChatZilla

You can install ChatZilla using Firefox.

1. Launch Firefox and from the top menu bar select **Tools > Add-ons > Get Add-ons**.

2. In the box to the left of the **Browse All Add-ons** link, type **ChatZilla** and press **Enter**.

3. Select **Add to Firefox** then **Install Now**. You may get a message to re-start Firefox.

#### 9.9.2. Configuring ChatZilla

1. Open Firefox.

2. On the top menu bar click **Tools > ChatZilla**.

3. The ChatZilla window opens where you will see the word *Client* in the middle of the page. At the bottom are links to a few of the most popular Networks. If your Network is among them just click on the link and ChatZilla will attach to it and automatically add it your **Preferences > Startup**.

4. To configure your chosen networks and channels so they automatically connect, select **Preferences > Startup** and scroll down to the **Auto-connect URLs** window, select the Network and click **Edit**. Now add `#your-channel` to the end, click **Apply** then **Ok**.

5. If your network is not listed, go to the top menu bar and choose **Preferences > Startup**, scroll down to the **Auto-connect URLs** window, click **Add**, and type in your network. For example, `irc://your.network`, click **Apply** then **Ok**.
6. If you know the channel you want to connect to automatically enter \texttt{irc://your\_network/\#your\_channel}. Don't forget to click the \texttt{Apply} and \texttt{Ok} buttons.

7. Finally, add few \textit{nicks} by selecting \texttt{Lists > Add}, typing in a nick and clicking \texttt{Ok}. Two or three nicks are recommended in case someone else is using your first choice.

\textbf{9.9.3. Using ChatZilla}

1. Open Firefox.

2. On the top menu bar click \texttt{Tools > Chatzilla} and you will automatically attach to your networks and channels.

\begin{quote}
\textbf{Note}

It is not necessary to have your channels connect when you start ChatZilla. Once you have attached to your networks you can select \texttt{IRC > Join channel} and type in your favorite channel, or part of it in the \texttt{Quick Search} box. Then click on the \texttt{Join} button when your channel appears in the box. But you will have to do these steps each time unless you setup ChatZilla to attach automatically.
\end{quote}
Chapter 10.

Office tools

There are two primary office suite recommendations for Fedora users: the OpenOffice.org suite which is not desktop- or even Linux-specific, and the KOffice suite for the KDE desktop. Each suite of office tools includes presentation, spreadsheet, and word processing applications. Additional office applications are also available depending on the office suite selected.

While the GNOME desktop does not have a specific office suite, there are a number of office application optimized for GNOME. These applications include Abiword, a word processing application that has plug-ins to make presentations and graphs, Gnumeric, a spreadsheet application, and gLabels, a program for creating labels and business cards.

Remember that any office application or suite will run on any Fedora desktop environment. The recommendation is only the office suite best optimized for a specific desktop environment, such as GNOME or KDE. Once installed, all office tools are available from the Applications > Office menu in GNOME, the Kickoff Application Launcher > Applications > Office menu in KDE, or as icons located in the menu bar or on the desktop.

To install the OpenOffice.org suite, refer to Chapter 17, Managing software. You can install them by either using the PackageKit application or on the command line by using Yum.

10.1. OpenOffice.org applications

OpenOffice.org creates documents in open standards formats, such as OpenDocument (.ODF), Rich Text Format (.RTF), and HyperText Markup Language (HTML). It can also read, edit, and write documents in Microsoft Office formats, such as Word (.DOC), Excel (.XLS), and PowerPoint (.PPT), with a high degree of compatibility. Files can be exported in PDF format without the need of additional software. The most used Openoffice.org programs are: Impress, Calc, and Writer.

For the most up-to-date information on all of OpenOffice.org's office program offerings, visit the official site at http://www.openoffice.org

For more information on using OpenOffice.org, refer to the following documentation and support pages:

• http://documentation.openoffice.org/

• http://support.openoffice.org/index.html

• http://wiki.services.openoffice.org/wiki/Documentation/FAQ

See also:

• http://documentation.openoffice.org/Samples_Templates/User/template/index.html – templates for all OpenOffice.org applications

• http://www.smalldataproblem.org/ooextras/ – artwork, labels, and Impress templates

• http://extensions.services.openoffice.org/project/SunTemplatepack_1 – professional template packs and extensions for “OpenOffice.org” applications

10.1.1. OpenOffice.org Impress

OpenOffice.org Impress Creates and performs presentations.
Chapter 10. Office tools

Start the application with Applications > Office > OpenOffice.org Impress in GNOME, or Kickoff Application Launcher > Applications > Office > Presentation in KDE.

The first window asks you to choose Empty presentation, From template or Open existing presentation.
- Click Empty presentation to build slides from scratch.
- Click From template to create a slide from a template:
  - Presentations allow you to choose:
    - Default
    - Introducing a New Product
    - Recommendation of a Strategy
  - Presentation Backgrounds loads the window with several background choices.
- Open existing presentation opens a presentation file.

If you chose to create a presentation from scratch or from a template, OpenOffice.org Impress helps you to set up your new presentation.

Click the Next button to Select a slide design and Select an output medium. Another click on Next opens the Presentation Wizard to set up your presentation. You can select the Effect and Speed of slide transition, and either Default or Automatic for the Type of Presentation you want. When building a presentation from a template there may be additional pages of questions such as the subject of the presentation or company name or the number of starting slides.

The Create button opens your presentation.

The application opens with the work area, top menu and a drawing menu on the bottom. When you roll your mouse over the icons a description of its function pops up. Click Help or press the F1 key, to open the OpenOffice.org Impress help manual.


10.1.2. OpenOffice.org Calc

OpenOffice.org Calc is a full-featured spreadsheet program.

Start the application with Applications > Office > OpenOffice.org Calc in GNOME, or Kickoff Application Launcher > Applications > Office > Spreadsheet in KDE.

The top bar contains the following menus:

File
- lets you create New documents, Open Close, Export and Print a file. This menu also contains the Wizards option that lets you create different templates.

Edit
- allows you to Cut, Copy, and Paste data, or to Delete Cells

View
- lets you select Toolbars, see Page Breaks, and Zoom in and out.
Insert
- lets you insert Cells, Rows, Sheets, Files, Pictures, Sounds, Functions, Special Characters, and Links.

Format
- lets you format Cells, Rows, Columns, and the Sheet. These controls also let you set up the Page and Print Ranges, and Change Case and Styles. They also let you Anchor, Align, Arrange, Flip, Group, and manipulate Graphics.

Tools
- let you check Spelling, access the Thesaurus, use the Detective, Goal Seek, Solver, and Scenarios filters, configure AutoCorrect, Share, Merge, and Protect the document. You can run Macros, Extension Manager, Customize the application, and set-up various Options.

Data
- lets you manipulate the data such as Define or Select Range, Sort, Filter, and Group and Outline.

Window
- lets you open a New Window, Close Window, and Split or Freeze the current window. It also lists any open files on the bottom of the drop-down menu.

Help
- opens the OpenOffice.org Calc, which you can also access with the F1 key.

The row of icons under the top menu bar contains the most frequently used functions plus a few icons for data manipulation.

The third menu panel allows you to configure the appearance of your data, such as font selection, text alignment, bullets, indentations, bolding, and italics.

The fourth panel shows the address of the cell you are pointing to and the data window shows what the cell contains.

The panel at the bottom of the spreadsheet shows which spreadsheet is currently selected and how many worksheets are in the file.

You can add new worksheets by clicking Insert > Sheet in the top menu panel. A dialog box opens which lets you choose the name of the new sheet and where it will be placed in relation to your existing worksheets. You can also add a new worksheet by right-clicking on a spreadsheet tab. This action opens a menu that allows you to Insert, Delete, Rename, Move/Copy, Select All, Cut, or Copy the spreadsheet.


10.1.3. OpenOffice.org Writer

OpenOffice.org Writer is a word processing program.

Start the application with Applications > Office > OpenOffice.org Writer in GNOME, or Kickoff Application Launcher > Applications > Office > Word Processor in KDE.

The top bar contains the following menus:
Chapter 10. Office tools

File
lets you create New documents, Open Close, Export and Print a file. This menu also contains the Wizards option that lets you create different templates.

Edit
allows you to Cut, Copy, Paste, Compare, or Select Text, and to turn on and configure Auto-Text, Find and Replace, and recording, protecting, comparing and merging Changes.

View
lets you select the type of Layout, Status Bar, Ruler, Toolbars, Text Boundaries, Field Names, Non-printing Characters, Hidden Paragraphs, Full Screen and Zoom in and out.

Insert

Format
lets you format Characters, Paragraphs, Bullets and Numbering, Page, Title Page, Change Case, configure Columns, Styles and Formatting. You can also Anchor, Wrap, Align, Flip, and Group text, and format Objects, Frames, and Pictures.

Tables
allows you to Insert, Delete, Select, and manipulate the Table's Cells. You can also format a Table's cells, rows and columns, add Formulas and access a Table's Properties.

Tools
gives you access to Spelling and Grammar, Language (which includes Thesaurus), Word Count, Auto correction, Outline Numbering and Line Numbering, Footnotes, Gallery, Media Player, Bibliography Database, and Mail Merge Wizard You can also Sort, Calculate, change and format Macros and Filters, Customize Menus, Keyboard, Toolbars and Events. Options lets you configure your User Data.

Window
lets you open a New Window, Close Window, and lists any open files on the bottom of the drop-down menu.

Help
opens the OpenOffice.org Writer, which you can also access with the F1 key.

The row of icons under the top menu bar contains the most frequently used functions plus a few icons for data manipulation.

The third menu panel allows you to configure the appearance of your document, such as font selection, text alignment, bullets, indentations, bolding, and italics.

The fourth panel shows the address of the cell you are pointing to and the data window shows what the cell contains.

The panel at the bottom of the document contains inset windows, some of which have menu access by double clicking on the window. This panel shows the number of pages the document contains, the page style being used, the language, an indicator of type over or insert, page layout view, and a zoom in and out bar.

10.2. KOffice

The KOffice suite is optimized for the KDE desktop environment. The KOffice applications also create documents and files in open standards formats including OpenDocument (.ODF), Rich Text Format (.RTF), and HTML. Officially, the KOffice FAQ recommends using .RTF or .PDF formats for compatibility with Microsoft Word.\(^1\) KOffice does support Microsoft file formats, but there are issues with compatibility.

For the most up-to-date information on all of KOffice’s program offerings, visit the official KOffice site at http://www.koffice.org/. This site also includes detailed documentation and help for each individual KOffice program.

For more information on using KOffice, refer to the overview at http://www.koffice.org/\(^2\), which also contains links to handbooks for the individual KOffice components.

10.2.1. KPresenter

KPresenter is the KOffice application for creating and performing presentations.

Open KPresenter by selecting the Kickoff Application Launcher > Office > Slide Presentations entry for KPresenter.

The first window contains options for opening Recent or Existing documents, the type of Template or Screen Presentation you want, as well as a menu bar.

On the menu bar,
- choose File to create a New file, Open or Import a file, or Quit the application.
- choose the Settings drop-down menu select Show Toolbar, Configure Shortcuts or Configure Toolbars.
- click Help to open the KPresenter Handbook or Report a Bug. You can also access the KPresenter Handbook by pressing the F1 key.

After selecting a template click the Use This Template button and check the box Always use this template if you want to make it the program default.

The next window has three menu panels on the top, a workspace with three windows, and a panel running along the bottom.

The first menu row consists of:
- File
  - allows you to create a New file, Open, Save, Import, Export, and Mail files. You can Create an HTML Slideshow or Memory Stick Slideshow, use the Template Manger, Use Current Slide as Default Template, Print, Preview, Close or Quit the presentation.

\(^1\) http://www.koffice.org/faq/#AretherefiltersforOpenOfficeWriterMSWordStarWriterRTF
Chapter 10. Office tools

Edit
lets you Undo, Redo, Cut, Copy, Paste, Delete, Select All, Deselect, Find, Replace, Copy Slide, Duplicate and Delete a Slide and to Duplicate an Object.

View
lets you select a New View, Close All Views, Split View, Remove View, Hide the Sidebar, Notebar, or Slide Master. It also allows Formatting of Characters, to show or hide Guide Lines, Grid, and the Snap to Grid, and Zoom in or out. When you select these options they appear in the work area windows.

Insert
allows you to add a Special Character, Variable, Link, Comment, Slide, File, Text, Chart, Table, Object, Picture, Line, Shape, or Scan Image.

Format
lets you select Rotate, Zoom, adjust the Properties, Arrange, Align, Group, Ungroup and Shadow Objects. Here you can also change the Page Layout, Slide Background, and Enable Document Headers and Footers.

Text
lets you switch to the Default Format, select Fonts, configure Paragraphs and color. The Style Manager lets your create your own styles or you can choose Style which lists the available styles. You can also Align the text, chose to add Numbers or Bullets by selecting Type. There are options to manipulate an Object, Change Case, turn on, or off, the Auto Spellcheck and Autocorrection.

Slide Show
allows you to configure the Slide Show, Objects, and Slide Transition. In this menu you can Start and Customize the slide show, and navigate the presentation manually.

Settings
lets you choose the Toolbars you want to use, you can Configure Autocorrection, Completion, Shortcuts, Toolbars, and KP presenter.

Help
opens the KP presenter Handbook (which you can also access by pressing the F1 key), lets you Report a Bug and offers general information about KP presenter and KDE.

The second row contains icons that are shortcuts of the top menu panel for File, Insert, Drawing, and Object formatting. Rolling your mouse over an icon opens a small window that lists its function.

The third menu panel is also made up of shortcut icons to work with Text and Slideshow configuration and navigation. Many of the icons in the menu panels are grayed out until a selection is made on the slide in the work area window.

The bottom panel shows the Slide number currently being worked on and the number of slides in the presentation, Main Slide Content or attributes, the Zoom percentage, and current measurement, Centimeters or Inches.

10.2.2. KSpread

KSpread is the KOffice spreadsheet program.

Open KSpread by selecting the Kickoff Application Launcher > Office > Spreadsheet entry for KSpread.

The first window contains options for opening Recent or Existing documents, and the type of Template, as well as a menu bar.

On the menu bar,
• choose File to create a New file, Open, Close or Import a file, or Quit the application.
• choose the Settings drop-down menu select Show Toolbar, Configure Shortcuts or Configure Toolbars.
• click Help to open the KSpread Handbook or Report a Bug. You can also access the KSpread Handbook by pressing the F1 key.

After selecting a template click the Use This Template button and check the box Always use this template if you want to make it the program default.

The next window has four menu panels on the top, the spreadsheet, and spreadsheet tabs running along the bottom.

The first menu row consists of:
File
  lets you create New documents, Open and Close a file, Save, Export, Import, Mail, Create a Template From Document, Print, and Quit the application.

Edit
  allows you to Cut, Copy, and Paste, Fill, Find, and Replace, Delete, Remove Links and change Cell Attributes.

View
  opens a new spreadsheet with New View, or allows access to Close All Views, Split or Remove View, Goto a Cell, Show Page Borders, and Zoom in and out.

Insert
  lets you insert Cell Comments, Functions, Series, Links, Special Characters, Objects, Charts, Pictures, or External Data such as information from a Database, Text File or the Clipboard.

Format
  lets you format the Cells, Rows, Columns, can be formatted, the Sheet can be Removed, Hidden and the Sheet Properties changed. Format can also be used to set up or create Styles, change the Page Layout and Print Ranges.

Data
  lets you manipulate the data such as Sort bring Text to Columns, Insert columns, Rows, Delete Columns or Rows, Insert, Remove, Merge, or Disassociate Cells, Show an Area, insert Subtotals, Goal Seek, or Consolidate formulas.
Tools can check Spelling, create Custom Lists, Protect Sheet and Document, Recalculate Sheet or Document, Insert Calendar. Tools can also access the Script Manager and Editor, and Export to HTML File.

Settings provides Hide the Status Bar, Tab Bar, and Formula Bar. Also use Settings to choose which Toolbars you want open, Configure Shortcuts, Toolbars, and KSpread.

Help opens the KSpread Handbook (which you can also access by pressing the F1 key), lets you Report a Bug and offers general information about KSpread and KDE.

The row of icons under the top menu bar contains the most frequently used functions plus a few icons for data manipulation.

The third menu panel allows configuration of the appearance of your data, such as font selection, alignment, font, bullets, indentations, bolding, and italics.

The fourth panel shows the address of the current cell and the data window shows what the cell contains.

The panel at the bottom shows in bold which spreadsheet is currently selected and how many worksheets are in the file. Worksheets can be added with a right mouse click on a worksheet tab. This pop-up window allows Rename the Sheet, Insert, Remove, Hide or Show the Sheet and provides access to Sheet Properties.


### 10.2.3. KWord

KWord is the KOffice word processing program.

Open KWord by selecting the Kickoff Application Launcher > Office > Word Processing entry for KWord.

The first window contains options for opening New Recent or Existing documents, the type of Template, as well as a menu bar.

On the menu bar,
• choose File to create a New file, Open, Close or Import a file, or Quit the application.
• choose the Settings drop-down menu select Show Toolbar, Configure Shortcuts or Configure Toolbars.
• click Help to open the KWord Handbook or Report a Bug. You can also access the KWord Handbook by pressing the F1 key.

After selecting a template click the Use This Template button and check the box Always use this template if you want to make it the program default.

The next window has three menu panels on the top, Frame shortcut icons on the left, the Document Structure window, the document work area, and an information panel running along the bottom.
The first menu row consists of:

**File**
- lets you create **New** documents, **Open** and **Close** a file, **Save**, **Export**, **Import**, **Mail**, **Create a Template From Document**, **Print**, and **Close** the file or **Quit** the application.

**Edit**
- allows you to **Undo**, **Redo**, **Cut**, **Copy**, **Paste**, **Select All**, **All Frames** or a single **Frame**. You can also **Find**, **Replace**, and **Delete Page**.

**View**
- lets you open a new document with **New View**, **Close All Views**, **Split** or **Remove View**, **Display Mode** for **Page**, **Preview**, and **Text Modes**. You can **Format Characters**, choose **Frame Borders**, **Hide Doc Structure** and **Rulers**, **Show Grid**, **Snap to Grid**, and **Zoom** in and out.

**Insert**
- lets you insert **Special Characters**, **Page Breaks**, **Pages**, **Footnotes/Endnotes**, **Table of Contents**, **Variables**, **Expressions**, **Links**, **Comments**, **Files**, **Bookmarks**, **Tables**, **Pictures**, **Text Frames**, **Object Frames**, or **Scan Images**.

**Format**
- lets you choose the **Default Format**, **Font**, **Paragraph**, **Footnotes**, **Formulas**, **Styles**, use the **Style Manager**, **Import Styles**, or **Create a Style From a Selection**. **Page Layout** can also be formatted and you can **Enable Document Headers and Footers**.

**Frames**
- allows you to set **Frame/Frameset Properties**, **Raise** and **Lower Frames**, **Bring to Front**, **Send to Back**, **Create a Linked Copy**, **Convert to Text Box**, and to use the **Frame Style Manager**, **Create Framestyle From Frame**, change the **Framestyle**, **Text Background Color**, and **Configure the Frame Border**.

**Table**
- allows you to change the Table's **Properties**, **Insert** and **Delete**, **Rows**, and **Columns**, **Join**, **Split** and **Protect Cells**, **Ungroup the Table**, **Delete a Table**, use the **Table Style manager** and choose from several **Tablestyles**.

**Tools**
- gives you access to **Spellcheck**, **Autocorrection**, **Change Case**, **Sort Text**, **Edit Personal Expressions**, **Add Expressions**, set **Custom Variables**, **Select Bookmarks**, and **Configure Mail Merge**.

**Settings**
- lets you choose which **Toolbars** you want open, **Configure Autocorrection and Completion**, **Configure Shortcuts**, **Toolbars**, and **Kword**.

**Help**
- opens the **KWord Handbook** (which you can also access by pressing the **F1** key), lets you **Report a Bug** and offers general information about **KWord** and KDE.

The row of icons under the top menu bar contains the most frequently used functions plus a few icons for text manipulation.

The third menu panel allows configuration of the appearance of your text, such as font selection, alignment, font, bullets, indentations, bolding, and italics.
Next to the work area is the **Document Structure** window which shows its structure, and icons for shortcuts to configure **Frames**.

The bottom panel shows the number of pages in the document, which page is in the work area window, whether **Insert** or **Typeover** is turned on, the **Zoom** in percentage, and the chosen measurement units.


### 10.3. GNOME office applications

Although GNOME does not have an office suite specifically designed for it, a number of office applications optimized for GNOME are available.

For more information on using these applications refer to [http://live.gnome.org/GnomeOffice](http://live.gnome.org/GnomeOffice)

#### 10.3.1. AbiWord

**AbiWord** is a word processing application optimized for the GNOME desktop.

Start **AbiWord** by clicking on **Applications > Office > AbiWord** in GNOME or the **Kickoff Application Launcher > Applications > Office > Word Processor** menu entry for **AbiWord** in KDE.

The functions of the top menu are:

**File**
- lets you create **New** documents, **New using a Template**, **Open** and **Import Files**, **Save** and **Revert** a file, **Page Setup** and **Print**, **Close** a file, or **Quit** the application. This menu will also show a list of recently opened files.

**Edit**
- allows you to **Undo**, **Redo**, **Cut**, **Copy**, and **Paste**, **Clear**, **Select All**, to **Remove Headers** and **Footers**, **Find and Replace**, **Goto** and to change the **Preferences**.

**View**
- lets you select the type of **Layout**, **Toolbars**, **Ruler** and **Status Bar**, **Enable Formatting Tools**, **Show Formatting Marks**, view a **Presentation**, **Full Screen** and **Zoom** in and out.

**Insert**
- lets you insert **Breaks**, **Page Numbers**, **Date** and **Time**, **Fields**, **Text Box**, **Mail Merge Field**, **Symbols**, **Headers** and **Footers**, **Files**, **Bookmarks**, **Hyperlinks**, **Table of Contents**, **Footnotes**, **Endnotes**, **Equations**, **Clip Art**, **Pictures**. **Objects** such as **GNOME Office Charts**, and **Direction Markers**.

**Format**
- lets you format **Fonts**, **Paragraphs**, add **Bullets and Numbering**, **Text Box**, **Images**, **Columns**, **Tabs**, **Headers/Footers**, **Footnotes and Endnotes**, **Table of Contents**. You can also **Align and Format** text, add a **Page Background** and **Create and Modify Styles**.

**Tools**
- lets you **Check Spelling**, **Set the Language**, **Word Count**, access the **Thesaurus**, **GDict Dictionary**, **Translators**, **Edit an Image via GIMP**, **Google Search**, **Summarize** the document, **URL Dictionary**, **Wiki Encyclopedia** change style with the **Stylist**, access the **Document...**
History and Revisions. You can also see the installed Plug-ins and install new ones, execute helper Scripts that you have created, and perform Mail Merge.

Table allows you to Insert, Delete, Select, and manipulate the table’s Cells. You can also format and merge a table’s Cells, Rows and Columns, Convert Text to a Table, Convert a Table to Text and turn on Autofit Table.

Collaborate lets you Share a Document or Documents and manage the collaboration Accounts.

Documents lets you open a New Window that lists any open documents.

Help opens Help Contents, Search for Help, Check for Updates, Report a Bug, and see general information About GNOME Office and About AbiWord.

The row of icons under the top menu bar contains the most frequently used functions that are listed in the top menu.

The third menu panel allows you to configure the appearance of your text, such as font selection, alignment, font, bullets, indentations, bolding, and italics.

The panel at the bottom of the document contains a window that shows the number of pages in the document and which page is currently displayed, an indicator that Type-Over or Insert is turned on, page layout view, and language in use.


10.3.2. Gnumeric
Gnumeric is a spreadsheet optimized for the GNOME desktop.

Start Gnumeric by clicking on Applications > Office > Gnumeric Spreadsheet in GNOME or the Kickoff Application Launcher > Applications > Office > Spreadsheet menu entry for Gnumeric in KDE.

Major functions of the top menu are:

File
lets you create New documents, Open, Save, Page Setup, Set, Clear and Show the Print Area. File also provides options to Print, Send To an email address, view and add to the program’s Properties, set Preferences, access a Full History, and Close a file, or Quit the program.

Edit
allows you to Undo and Redo actions, Cut, Copy, and Paste and Fill, Clear, and Delete Rows, Columns, and Cells. Edit also provides options to Find, Replace or Goto a Cell, manage the Sheets, Select various ranges in the spreadsheet, and Recalculate.

View
allows you to create a New View of the workbook, to Freeze Panes, select a different Workbook, choose Toolbars, View Statusbar, Full Screen and Zoom in and out.
Chapter 10. Office tools

Insert
lets you insert Cells, Columns, Rows, Charts, Images, Functions, Names, Comments, Hyperlinks and Special fields such as Current Date, Current Time and Current date and time.

Format
lets you format the Cells, Rows, Columns, Sheets and Workbook can be formatted and Preferences changed. Use Autoformat to format a region of cells according to a pre-defined template.

Tools
provides Auto Correct, Auto Save, Goal Seek, Solver, View and Add Scenarios, Simulation, Statistical Analysis and manage Plug-ins.

Data
allows manipulation of the data such as Sort, Filter, Validate, Consolidate, create a Table, Group and Outline, convert Text to Columns and Get External Data.

Help > Contents
opens the Gnumeric help manual (as does the F1 key), Gnumeric on the Web, Live Assistance, and Report a Problem.

The row of icons under the top menu bar contains the most frequently used functions that are listed in the top menu.

The third menu panel allows you to configure the appearance of your data, such as font selection, alignment, font, bullets, indentations, bolding, and italics.

The fourth panel shows the address of the cell you are pointing to and the data window shows what the cell contains.

The panel at the bottom of the spreadsheet shows which spreadsheet is currently selected, how many worksheets are in the file, and a function's result in the cell to which you are pointing. You can add or change a worksheet by:

- a right mouse click on one of the tabs, then choosing from the menu.
- clicking on Edit > Sheet in the top menu.


10.3.3. gLabels
gLabels is a light-weight GNOME application for creating labels, business cards, and labels for CD and DVDs.

Start gLabels by clicking on Applications > Office > gLabels Label Designer in GNOME or Kickoff Application Launcher > Applications > Office > gLabels Label Designer in KDE.

The major functions of the top menu are:

File
lets you create a New project, Open, Open Recent files, Save, Save As, Print, change Properties open the Template Designer Close a file, or Quit the program.
**Edit**
- allows you to **Cut**, **Copy**, and **Paste**, **Delete Select All**, **Unselect All** and change the **Preferences**.

**View**
- lets you choose **Toolbars**, customize the toolbars, turn on the **Grid** and **Markup**, and **Zoom** in and out.

**Objects**
- lets you **Select Mode**, **Create Text**, a **Box**, **Line**, **Ellipse**, **Image**, a **Barcode** define the **Order**, **Rotate/Flip**, **Align Horizontal** or **Vertical** and **Merge Properties**.

**Help > Contents**
- opens the **gLabels** help manual (as does the **F1** key), or lets you see general information **About** the program.

The row of icons under the top menu bar contains the most frequently used functions that are listed in the top menu.

The third menu panel is grayed-out until you select a **New** project or **Open** an existing file. These icons allow you to **Select**, move and modify objects, **Create text object**, **Create box/rectangle object**, **Create a line object**, **Create ellipse/circle object**, **Create Image Object**, **Create a Barcode**, **Zoom** in and out, and **Edit merge properties**.

The panel at the bottom of the work window allows you to configure the appearance of your data, such as font selection, alignment, bolding, and italics, as well as text and line color.

For more information on using **gLabels**, refer to the gLabels website at [http://glabels.sourceforge.net/](http://glabels.sourceforge.net/).
Financial software

Fedora offers software financial software for both the GNOME and KDE environments. **GnuCash** is the financial software recommended for users with the GNOME desktop environment, and **KMyMoney** is recommended financial software for the KDE environment. Although each financial software application is recommended for a specific desktop environment, remember both will work on any Fedora desktop environment. Both applications can be used for personal and business, and configured for online banking.

**GnuCash** and **KMyMoney** are not installed by default from the Live CD or the DVD. If you do not have access to the Internet, you can install them with the Fedora DVD. Refer to Chapter 17, Managing software for instructions. You can install them by either using the PackageKit application or on the command line by using **Yum**.

### 11.1. GnuCash

**GnuCash** allows you to track personal and business bank accounts, stocks, income and expenses, and is based on double-entry accounting principles.

For additional help using the application, refer to [http://www.gnucash.org/docs.phtml documents](http://www.gnucash.org/docs.phtml)\(^1\).

#### 11.1.1. Configuring GnuCash

To configure GnuCash:

1. Start **GnuCash** by clicking **Applications > Office > GnuCash Finance Management**. Click the **Close** button to close the **Tip of the Day** window.

2. From the **Welcome Window** select which wizard you want to open and click the **OK** button.

3. Select **Create a new set of accounts** and click the **Forward** button on the **Setup Account Hierarchy** window.

4. Choose your currency and click the **Forward** button.

5. Select all of the boxes next to the accounts you want to create in the **Categories** window, then push the **Forward** button.

6. Follow the directions in the **Setup new accounts** window, then click **Forward**.

7. Click the **Apply** button to finish your account setup.

8. To import a Quicken .qif file, select the box then press the **Forward** button.

9. Select the .qif file to load and click the **Forward** button.

10. Now you have the option to load more QIF files for additional accounts. Select the **Forward** button.

11. Pressing the **Forward** button guides you through Matching QIF accounts with GnuCash account, Matching QIF categories with GnuCash accounts, and currency selection.

12. Click the **Apply** button to import your data, or the **Back** button to review your matchings.

\(^1\) [http://www.gnucash.org/docs.phtml](http://www.gnucash.org/docs.phtml)
11.1.2. Using GnuCash

Open GnuCash by selecting Applications > Office > GnuCash on the top menu panel. The Accounts tab opens.

The top menu bar allows you to manipulate your accounts. You can:

- **Edit**, **Delete** and **Create new accounts**.
- **Set Preferences**.
- **Schedule Transactions**.
- **Do transfers**.
- **Reconcile** an account.
- **Enter Stock Splits**.
- **Add Customers**, **Vendors**, and **Employees** for a business.
- **Set Reminders**.
- **Generate Reports**.
- **Setup Online Banking**.
- **Edit Prices** of inventory.
- **Access the General Ledger**.

Double click on an account to bring up a check book type register for that account. The top menu bar changes to allow manipulation of transactions. This menu includes the options above, plus you can:

- Change the view of the ledger from **Basic Ledger** to **Auto-Split Ledger**, **Transaction Journal**, or **Double Entry**.
- **Cut**, **Copy**, **Paste**, **Duplicate**, **Delete**, **Void**, and **Enter** transactions.
- **Set Billing Terms** for customers.
- **Create Bills**, **Invoices**, and **Vouchers**.

11.1.3. Setting up online banking

Online banking setup begins from the Accounts window or the Register.

1. On the top menu bar select **Tools > Online Banking Setup**.

2. The **Initial Online Banking Setup** window lists what you need to complete the setup.

3. Click the **Forward** button.

4. Select the **Start AqBanking Wizard** in the **Start Online Banking Wizard** window.

5. The **Configuration** window **Intro** provides a summary of what you can do.

6. Type in the information required in the **Users**, **Accounts**, and **Backends** tabs on the top of the window.
7. Select the **OFX-Direct** backend if you are not sure which one to use.

8. You may need to call your bank to get their server URL. If you chose the **OFX-Direct** backend it is likely their URL is `https://ofx.yourbank.com/`.

9. Return to the **Start Online Banking Wizard** and click the **Forward** button.

10. Check the appropriate boxes under the **New?** column to match the bank accounts with your **GnuCash** accounts.

11. Click the **Forward** button.

12. Click the **Apply** button to finish.

13. To download your bank transactions select the **Accounts** or **Register** tab then: **Actions** > **Online Actions** > **Get Transactions** or > **Get Balance** and fill in the information asked for to complete the operation.

### 11.2. KMyMoney

**KMyMoney** is a double entry accounting software package, for personal and small business use.

For additional help using **KMyMoney**, refer to [http://kmymoney2.sourceforge.net/faq.html](http://kmymoney2.sourceforge.net/faq.html).

#### 11.2.1. Configuring KMyMoney

1. Open **KMyMoney** by selecting **Kickoff Application Launcher** > **Applications** > **Office** > **Personal Finance Manager**.

2. Click the **Next** button on the **Welcome to KMyMoney** screen.

3. Type in the information and press **Next**.

4. Select your currency and click **Next**.

5. Now type in the information for your bank account. Then select **Next** again.

6. Find your country and click on the + next to its name.

7. Select the type of account you want setup, then click **Next**.

8. Press the **Configure preferences now** button.

9. You can keep the default path where **KMyMoney** will save your files, type in a path, or browse by clicking the button maked with a small folder on the right of the path window.

10. Click the **Finish** button and your **Home** window opens.

11. Open the account register by clicking on your account’s link in **Your Financial Summary** window.

12. Click the **Show KMyMoney welcome page** link at the bottom to:
   - **Set Up a New Data File**.
   - **Use an Existing Data File**.
   - **Visit the KMyMoney Website**.
11.2.2. Using KMyMoney

The top menu bar contains the following options:

- **File**
  - Create, Open, and Save files.
  - Import QIF, GnuCash, and OFX files.
  - Export QIF files.
  - Backup your data.
  - Edit your personal information.

- **View**
  - Show Transaction Details.
  - Hide reconciled transactions.
  - Hide unused categories.
  - Show all accounts.

- **Institution**
  - Set up a New Institution.
  - Edit an institution.
  - Delete an institution.

- **Account**
  - Create a New account.
  - Edit accounts.
  - Delete accounts.
  - Open the ledger.
  - Reconcile.
  - Close or Reopen an account.
  - Map, Unmap, and Update an online account.

- **Category**
  - Create, Edit or Delete a category.
  - Open the ledger.

- **Transaction**
  - Create, Edit, Delete, and Mark transactions.
• **Goto account** and **Goto payee**.

• **Match, Accept, Combine**, or **Select all** transactions.

• **Tools**
  • QIF Profile, Securities, Currencies,'' and "Prices Editor."
  • Update Stock" and "Currency Prices."
  • Consistency" and "Performance Tests."
  • Plug-ins."  
  • Option to "Debug Traces" and "Timers."

• **Settings**
  • **Hide the Toolbar** and **Statusbar**.
  • **Enable all messages**.
  • **Change the KDE language settings**
  • **Configure Shortcuts, Toolbars** and **KMyMoney**.

• **Help**
  • **KMyMoney Handbook**
  • **Bug Report**
  • **program information**.

### 11.2.3. Setting up online banking

1. Click the **Institutions** icon on the left panel to make sure your bank information is linked to your new account.

2. Highlight your account under the bank in the main window.

3. On the top menu, choose **Account > Map Account** and the program will load a list of financial institutions in the **Online Banking Account Setup** window.

4. Type the name of your bank in the **Search** bar, or scroll down the list to find it.

5. Click on your bank's name to select it then press the **Next** button.

6. Fill in your **Username** and **Password**.

7. Choose an option for **Identify as** and click the **Next** button.

8. This window shows the accounts you have available at the bank. Click on the whichever one you want to link to your **KMyMoney** account and click **Next**.

9. Click the **Finish** button to complete the setup.
10. Press the blue icon on the top menu to **Update the Account** or select **Account > Account update** also on the top menu bar.

11. The program connects to your bank and the **Account selection** window asks you to which **KMyMoney** account you want to download information. You also have the option here to **Create** a new account.

12. Select your account and click **Ok**.

13. The **Statement stats - KMyMoney** window summarizes the information downloaded. Click the **OK** button.

14. Click the **Ledger** icon on the left menu panel to see the loaded information.
Playing multimedia

Media formats not supported by default in Fedora
Because of licensing and patent encumbrances, Fedora cannot ship with certain audio and video playing capabilities, known as codecs. An example is the MP3 codec. Refer to Fedora Project's Approach to Multimedia Support, for more information.

Fedora includes several tools for listening to audio and viewing video on both the GNOME and KDE desktops. These applications will run in either Fedora desktop environment. To install software packages not already installed, refer to Chapter 17, Managing software. You can install applications by either using the PackageKit application or on the command line by using Yum.

Fedora provides the following applications for audio and video by default:

- **Amarok** is a music player that features tools for organizing music, CDs, Internet radio stations, and more, and is included in KDE by default.

- **CD/DVD Creator** is an application for listening to audio CDs in GNOME.

- **Cheese Webcam Booth** takes photos and videos with your webcam is installed in GNOME and KDE.

- **Dragon Player** is a simple video player in KDE.

- **JuK** is a collection and playlist manager as well as a music player installed in KDE.

- **Kaffeine** is an application for viewing videos in KDE.

- **KMix** is a Sound Mixer for KDE.

- **KsCD** is an application for listening to audio CDs in KDE.

- **Rhythmbox** is a music player that features tools for organizing music, CDs, Internet radio stations, and more, and is included in GNOME and KDE by default.

- **Sound Juicer** is an application for converting CDs to music files (also known as ripping) in GNOME and KDE.

- **Sound Recorder** can record and play .flac, .oga (OGG audio), and .wav sound files.

- **Totem Movie Player** is an application for viewing videos in GNOME and KDE.

To open these programs, in the GNOME desktop, click on their entries in the Applications > Sound and Video menu in the top menu bar. In the KDE desktop, click on their entries in the Kickoff Application Launcher > Applications > Multimedia menu.

12.1. The Fedora Project's approach to multimedia support
In short, the Fedora Project encourages the use of open formats in place of restricted ones.

Fedora includes complete support for many freely-distributable formats. These include the Ogg media, Vorbis audio, Theora video, Speex audio, and FLAC audio formats. These freely-distributable formats are not encumbered by patent or license restrictions, and provide powerful and flexible alternatives.
to popular yet restricted formats such as MP3 that are not legally distributable with Fedora. For more information, refer to the Fedora Multimedia wiki at https://fedoraproject.org/wiki/Multimedia.

12.2. Cheese Webcam Booth

Cheese Webcam Booth takes photos and videos with your webcam.

12.2.1. Using Cheese Webcam Booth

The top menu provides the following operations and options:

- Selecting Cheese you can choose to turn on the Countdown timer, Take a photo or Record, depending on if you selected Photo or Video button, see the Fullscreen, and Quit the application.

- Edit lets you turn on Effects, Move to Trash, Move All to Trash, and change the Preferences.

- Clicking on Help > Contents, or pressing F1, opens the Cheese Manual.

The tabs, between the windows, are shortcuts of the choices in top menu.

More information is available on the Cheese website at http://www.gnome.org/projects/cheese

12.3. Rhythmbox Music Player

Rhythmbox Music Player plays CDs, internet radio, and is a music collection manager.

The first time you launch the Rhythmbox Music Player, an assistant will help you import your music. On the second panel of the assistant, click the Browse button and select the folder where your music is stored, normally in your /Home/Music/ directory.

12.3.1. Using Rhythmbox Music Player

The main functions of the Rhythmbox Music Player window are:

- The top panel Menu bar which has all of the menus to perform tasks. Press F1 or click Help > Contents on the menu bar to open the manual.

- The second Toolbar panel accesses the player functions and provides details about the track that is playing.

- A Time Slider, under the Toolbar panel, displays the position of the read of a track and allows you to jump to another part of a track.

- In the left window the Source List lets you access your music library, internet radio, internet, your playlist, and CDs. This consists of:
  - The Rhythmbox Music Player library, where all of the imported tracks are saved.
  - The Radio with internet radio stations.
  - Podcasts.
  - Online Stores:
    - All Playlists (normal and smart).
  - Audio CDs inserted into the computer’s drives.
• Portable players, such as an MP3 player, plugged in to your computer.

If you have a wheel mouse you can adjust the volume by placing the cursor on the volume icon and turning the wheel.

In the Browser, the rectangle window right of the Source List, you can browse and filter the Library tracks by genre, artist, or album name. It also provides a Search function.

The Tracks list is the bottom window and contains the lists of the tracks that belong to the source you selected.

The Statusbar is the panel that runs along the bottom that displays information about the source you selected.

Visit the Rhythmbox website at http://projects.gnome.org/rhythmbox/ for more information.

12.4. Audio CD Extractor (Sound Juicer)

Audio CD Extractor (Sound Juicer) lets you extract the audio from CDs and convert them to audio files your computer can play. This program also plays CDs.

12.4.1. Using Sound Juicer

To enter track data, insert an audio CD and Sound Juicer will locate and retrieve the data from MusicBrainz (a free service). If MusicBrainz cannot match the CD you have the option to enter the track information manually. The notifier will also ask you if you want to submit your album to the MusicBrainz database. You will need to open a MusicBrainz account to submit albums to their database.

To enter track data manually:
1. Fill in the text boxes for the title, artist, year, and genre of the CD.

2. Below that is a list of the audio tracks on the CD. You can determine the track title and artist for each track.

To edit the title of a track, first select the track, then click on the title. When you have finished entering the title, press the Enter key. Each track of the CD is automatically updated if they matched the artist before the edit.

Extracting Track Data:
1. Select the tracks you want to save by clicking on the boxes in front of the tracks. You can also use Edit > Select All or Edit > Deselect All.

2. Click the Extract button. This will change to a Stop button when the program begins to extract the data. You will see an icon next to the track being extracting.

Press F1, or Help > Contents to see the manual.

For more information see the Sound Juicer website at http://burtonini.com/blog/computers/sound-juicer

12.5. Sound Recorder

Sound Recorder can record and play .flac, .oga (OGG audio), and .wav sound files.
Chapter 12. Playing multimedia

12.5.1. Using Sound Recorder

- From the top menu select File > New, or press the New button on the second panel.
- On the Record as drop-down menu choose what type of file you want to record to.
- Press the red Record button or select Control > Record from the top menu to start recording.
- Press the Stop button or use Control > Stop, on the top menu, to end the recording.
- Press the Play button or Control > Play to start the play-back.
- To open the audio mixer select File > Open Volume Control.
- To save your file choose File > Save As, and name your sound file.
- You can play an existing sound file by clicking the Open button, or selecting File > Open on the top menu, choose the file and click the Open button. Now press the Play button, or Control > Play, to play the selected file.
- Selecting File > Properties displays information about the current sound file.
- Access the Sound Recorder manual by choosing Help > Contents or press the F1 key.

12.6. Totem Movie Player

Totem Movie Player plays DVDs, CDs, and VCDs.

12.6.1. Using Totem Movie Player

- To open an audio or video, file, select Movie > Open. Select the file you want and click the +Add button. You can also drag a file in to the Totem Movie Player window. If Totem Movie Player displays error messages when you try to play a file, refer to the information about codecs at http://www.gnome.org/projects/totem/#codecs.
- Click Movie > Open Location to open a file by URL location.
- Movie > Play Disc will play a DVD, VCD, or CD.
- Movie > Eject will eject the disc.
- Under the Eject option is the Playlist.
- Movie > Play and Movie > Pause will play or pause the disc.
- Choosing Movie > Properties opens the sidebar which displays the properties of the file.
- From the Edit menu you can Take a Screenshot, Copy, Select All, Find, Find Next, go to the Previous file, configure Plugins and set Preferences.
- View allows you to go to Fullscreen, Fit Window to Movie, set the Aspect Ratio, Switch Angles, Show Controls, Subtitles, and show, or hide, the Sidebar.
- Go will let you go to the DVD, Title, Audio, Angle and Chapter menus, the Next Chapter or Movie the Previous Chapter or Movie, Skip to a track, and Skip Forward or Backwards.
• The **Sound** drop-down menu lets you change **Language** and turn the **Volume Up** or **Down**.

• You can open the manual by selecting **Help > Contents** or pressing the **F1** key.

For more information visit the **Totem Movie Player** website at [http://projects.gnome.org/totem/](http://projects.gnome.org/totem/).

### 12.7. GNOME multimedia applications

#### 12.7.1. CD/DVD Creator

**CD/DVD Creator** is a CD and DVD burner.

#### 12.7.1.1. Using CD/DVD Creator

To open select **System > CD/DVD Creator**. You can access the Help manual can be accessed by pressing the **F1** key or clicking **Help > Contents** on the top menu bar.

To create a data disc:

1. Drag the files and folders, that you want to write to CD or DVD, to the **CD/DVD Creator** folder.

2. Insert a writeable CD or DVD into your writer device. Doing this step first usually opens the **CD/DVD Creator** automatically. You can configure the **CD/DVD Creator** to open automatically by going to **System > Preferences > Hardware > Multimedia Systems Selector** and on the **Audio** and **Video** tabs select **Autodetect** from the drop-down menu.

3. Click the **Write to Disc** button, or choose **File > Write to CD/DVD**. Choose to write to your **CD/DVD** or to a **File Image**. An image file (ISO) is a normal file that will be saved to your computer and you can write to a CD later.

   You can type a name for your CD or DVD in the **Disc name** window and select a **Write speed** from the drop-down under **Write Options**. You will also see the size of your data that will be written to the disc.

4. Press the **Write** button to copy your data to the CD/DVD.

To write a disc image to a CD/DVD, right-click on the **Disc Image File**, then choose **Write to Disc** from the popup menu.

To make a copy of a CD or DVD

1. Insert the disc you want to copy.

2. Choose **Places > CD/DVD Creator** from the top panel menu bar.

3. Right-click on the **CD** icon, and choose **Copy Disc**.

4. Follow the **Write to Disc** dialogue as above.

   If you have only one write drive the program will first create a file on your computer. The original disk will be ejected, and ask you to change it for a blank disk to copy on.
12.8. GNOME multimedia applications in the repository

These applications are not usually installed by default but are in the Repository. To install them, refer to *Chapter 17, Managing software*. You can install applications by either using the PackageKit or on the command line by using Yum.

12.8.1. Brasero

Brasero copies and burns music, or data, to CDs and DVDs. Refer to [http://projects.gnome.org/brasero/](http://projects.gnome.org/brasero/) for details.

12.8.2. GnomEBaker

GnomEBaker can burn music or data to a CD. Refer to *Section 6.2.3, “Using GnomeBaker in Gnome”* or the GnomEBaker website at [http://www.biddell.co.uk/gnomebaker.php](http://www.biddell.co.uk/gnomebaker.php) for more information.

12.9. KDE multimedia applications

The KDE desktop groups multimedia applications together in the Kickoff Application Launcher > Applications > Multimedia menu.

12.9.1. Amarok

Amarok is a CD player and music collection manager. For more information refer to the Amarok website at [http://amarok.kde.org/](http://amarok.kde.org/)

12.9.1.1. Using Amarok

- Click Play Media to play existing sound files, go to a Previous Track, Play/Pause, Stop go to the Next Track or Quit the application.
- Playlist lets you Add Media, Add Stream, Save Playlist, Undo, Redo, Clear Playlist, Repeat and choose Random play.
- Tools lets you access the Cover Manager Script Manager and to Update Collection.
- Under Settings you can Configure Shortcuts and Configure Amarok.
- Clicking Help > Amarok Handbook, or pressing the F1 key opens the manual.
- On the left side of the application window you can select the Files you want to play, Playlist, Collections or access the internet for music, podcasts and radio stations. Details about your selection are displayed in the window to the right.
- The bottom center icons are: + adds a widget, - deletes a widget, the arrows let you go to a Previous or Next Group, and you can Zoom in or out.
- In the Playlist window you can do a Search, go to the Next or Previous selection, and Search Preferences. The options along the bottom allow you to Clear Playlist, Show Active Track, Undo, Redo, Save a Playlist, and Export a Playlist As.
12.9.2. Dragon Player

Dragon Player is a simple video player. For more information refer to the Dragon Player website at http://dragonplayer.org/

12.9.2.1. Using Dragon Player

• When you first open Dragon Player a pop-up window asks what you would like to Play File or Play Disc. If you choose one of these the program loads the file. You can also Close the window or Quit the application.

• Selecting Play > Play Media allows you to play a DVD, VCD, or Video File, Play/Pause lets you pause and re-start the movie, Stop will stop the playback, and Quit closes the application.

• The Settings menu lets you choose the Full Screen Mode, Aspect Ratio, Subtitles, Audio Channels, to Configure Shortcuts and Toolbars or to Show Toolbar.

• Help > Dragon Player Handbook, or pressing the F1 key, opens the manual.

12.9.3. JuK

JuK is a collection and playlist manager as well as a music player. For more information refer to the JuK website at http://developer.kde.org/~wheeler/juk.html

12.9.3.1. Using JuK

• When the application opens you can choose to Add or Remove a Folder, and Import playlists, from the pop-up window.

• Selecting File on the top menu bar, you can choose to open a New file, Open an existing file, Add Folder, Rename, Edit, Search, Duplicate, Reload, Remove Save, Save As or Quit the application.

• Edit allows you to Undo, Cut, Copy, Paste, Clear or Select All.

• Under View you can configure “JuK” to Show the Search Bar, Show Tag Editor, Show History, Show Play Queue or Columns, Resize Playlist Columns Manually and View Modes (Default, Compact or Tree).

• From the Player drop list you select to Random Play, Loop Playlist, Play, Pause, Stop, Next, Previous and Play the Next Album.

• Tagger lets you Save or Delete tags, Refresh, Guess Tag Information open the Cover Manager and Rename a File.

• From the Settings menu you can choose which Toolbars to display, Show Splash Screen on Startup, Dock in System Tray, Stay in System Tray on Close, Open Track Announcement, Tag Guesser, File Renamer and Configure Shortcuts or Toolbars.

• The second menu panel displays icons of the most used commands, which are also located in the top menu bar.

• The right window is home to your collection or playlist.
Chapter 12. Playing multimedia

- The main window displays information about the file, such as: **Track Name**, **Artist**, **Album**, **Cover**, **Track**, **Genre**, **Year** and **Length**.

- To open the manual select **Help > JuK Handbook** or press the **F1** key.

### 12.9.4. Kaffeine

**Kaffeine** is a media player that can play streaming content, DVBs, DVDs, and CDs. To get streaming content over the web, you need a Mozilla plug-in for the program, which is available from [http://sourceforge.net/project/downloading.php?groupname=kaffeine&filename=kaffeine-mozilla-0.2.tar.bz2&use_mirror=internap](http://sourceforge.net/project/downloading.php?groupname=kaffeine&filename=kaffeine-mozilla-0.2.tar.bz2&use_mirror=internap). For more information about **Kaffeine** generally, refer to the **JuK** website at [http://kaffeine.kde.org/](http://kaffeine.kde.org/)

#### 12.9.4.1. Using Kaffeine Media Player

The first window that opens contains five shortcut icons:

- **Play Playlist** takes you to a current playlist.

- **Audio CD encoding** will help you rip tracks from a CD.

- **Play Audio CD** plays a CD.

- **Play DVD** plays a DVD.

- **Play VCD** plays a VCD.

On the left side of the window are four small icons:

- The KDE icon,” on top, brings up the first window, wherever you are in the program.

- The Kaffeine icon opens the **Player Window**.

- Clicking the next icon opens the **Playlist**.

- The disc icon’ takes you to the **Play CD window** that lists the details of the CD.

The toolbar along the bottom of this window allows you to **Play**, **Pause**, **Skip Backward** or **Forward**, **Stop**, and **Adjust the Volume**.

The top menu panel has:

- **File** which allows you to **Open a File**, **URL** or **Directory**, **Open a DVD**, **VCD**, **Audio CD** and **Network Broadcasting**. You can also **Save Stream**, **Save a Screenshot**, **Quit with Options**, or **Quit**.

- From the **View** menu you have the options for the **Full Screen Mode**, **Minimal Mode**, **Toggle Playlist/Player**, **Enable Auto Resize** or **Keep Original Aspect**.

- Selecting **Player** gives you the option to **Play**, **Pause**, **Stop**, go to the **Next** track or **Previous** track, **Fast Forward**, **Slow Motion**, and **Jump to Position**. You can also **Navigate** a **DVD**, **CD**, **Video**, configure **Subtitles**, access **Track Info** and enable or disable **Plugins**.

- The **Playlist** drop-down lets you **Shuffle**, **Repeat**, **Download covers**, **Clear Current Playlist**, start a **New Playlist**, **Import**, **Save** or **Remove a Playlist**.

- **Settings** allow you to select a **Player Engine** (Xine or GStreamer), choose the **Toolbars**, **Configure Shortcuts**, **Toolbars** and **Kaffeine Player**, and to set **xine Engine Paramenters**.
• Clicking Help > Kaffeine Player Handbook or pressing the F1 key, opens the manual.

12.9.5. KMix

KMix is a sound mixer that allows you to control volume settings for sound inputs to and outputs from your computer. For more information refer to the KMix website at http://docs.kde.org/stable/en/kdemultimedia/kmix/index.html

12.9.5.1. Using KMix Sound Mixer

The application window has three sections with different controls: Output, Input and Switches. These sections contain volume sliders, switches for enabling/disabling record or playback, and multiple-choice selectors.

• Output controls are playback-related, like the Master volume control.

• Input controls are recording-related, like Capture.

• Switches has all controls allowing you to switch some functionalities ON or OFF (like Mic Boost (+20dB)), and multiple-choice controls (like Mic Select: Mic1 or Mic2).

KMix also features LEDs.

• Green for playback

• Red for recording

• Yellow is for special soundcard functions

Most of these controls have a context menu, you can access by a right mouse click on the icon.

• For Split Channels the right slider controls right side volume, and the left controls left side volume.

• Muted can be on or off.

• You can select Hide to hide this device

To configure KMix from the menubar choose Preferences > Use Settings > Configure KMix The options are:

• Dock into panel will dock in the systray when pressing the window Close button.

• Show labels will display labels for each of the sound devices.

• Show lines to mark positions on the sliders.

12.9.6. KsCD

KsCD is a simple CD player.

12.9.6.1. Using KsCD

The button cluster on the left side contains:

• Play in the center.

• Previous to the left.

• Next on the right side.
Chapter 12. Playing multimedia

- **Stop** on the bottom.
- **Eject** on the top.

The center window displays information about the file being played.

The icons along the bottom allow you to setup **Random play**, **Loop**, **Tracklist**, and **Mute**.

The three buttons on the top and center right are:
- **Volume control** – place your cursor on the white dot, hold down the right mouse key and drag it to the desired level.
- The - button lets you minimize **KsCD**.
- The X icon closes the application.

12.10. Multimedia Programs in the Repository

The applications below are not usually installed by default but are in the Repository. To install these packages please, read [[User Guide - Managing Software|the chapter on managing software]]. You can install applications either by using the **PackageKit** application or on the command line by using **Yum**. Refer to **Chapter 17, Managing software** for more information.

12.10.1. K3b

**K3b** is a CD and DVD burning application. Refer to **Section 6.2.2, “Using K3b to burn media in KDE”** or the K3b website at [http://www.k3b.org/](http://www.k3b.org/) for more information.

12.11. MP3 Players

Personal digital media players can be used to store and listen to music away from a computer. These are often referred to as **MP3 players** a potentially misleading name; not all of these players use MP3 files to store music.

Many mp3 players can be mounted as storage mediums, and music can be added to them just like a file can be added to any other disk. See **Chapter 6, Media** for more information.

Some players, however, require special applications to transfer music.

12.11.1. Grip

**Grip** is a CD player and a ripper for the Gnome desktop. It provides an automated frontend for MP3, and other audio format, encoders, letting you transform the disc straight into MP3s. Internet disc lookups are supported for retrieving track information. Details are available on the **Grip** website at [http://nostatic.org/grip/doc/index.html](http://nostatic.org/grip/doc/index.html)

**Grip** is not installed by default but it is in the repository for installation with either using the **PackageKit** application or on the command line by using **Yum**. Refer to **Chapter 17, Managing software** for more information.

12.11.2. iPod Connectivity

Because of the proprietary nature of the Apple iPod, it can be difficult to use it with a computer with a Linux operating system like Fedora. Unfortunately, Apple has not (and has never announced plans
to) release a Linux version of iTunes, and iTunes is not yet stable through Wine (a piece of software that allows many programs designed for Windows to work on Linux). Luckily, there are several high-quality tools available for Linux users to manage media content on the iPod. Among them are gtkpod, YamiPod, and tools built into media players such as AmaroK, Rhythmbox, and Banshee.

The Fedora Project does not by default offer the ability to interact with the Apple iPod. However, you can use Gtkpod can be used to sync music, podcasts, and other content to your iPod.

Gtkpod is not installed by default from the Live-CD or the DVD. If you do not have access to the Internet, you can use the Fedora DVD to install Gtkpod. You can install applications with either using the PackageKit application or on the command line by using Yum. Refer to Chapter 17, Managing software for more information.

Start Gtkpod by clicking Applications > Music and Video > gtkpod in GNOME or Kickoff Application Launcher > Applications > Multimedia > iPod Manager.

For further help on iPod support through Gtkpod, refer to the Gtkpod website at http://www.gtkpod.org/about.html.

12.12. Further Information

For more information on freely-distributable formats and how to use them, refer to the Xiph.Org Foundation's web site at http://www.xiph.org
Chapter 13.

Playing games

A Fedora installation includes a selection of games by default. You can also select additional game packages during or after installation. To install new games on your Fedora system, refer to Chapter 17, Managing software. You can find more information about games for Fedora at https://fedoraproject.org/wiki/Games. For more information about the games in this list, refer to the Help menu within each individual game.

You do not need to switch desktops to play games

You can play KDE games while logged into GNOME and GNOME games while logged into KDE. Graphical environment components are very modular. When you install the game packs any dependencies will also be installed. You may need additional packages to view the online help.

13.1. Default GNOME games

Many GNOME games are not installed by default from the Live-CD or the DVD. If you do not have access to the Internet, you can use the Fedora DVD to install them, either using the PackageKit application or on the command line by using Yum. Refer to Chapter 17, Managing software for help installing new software. Be sure to also install the separate Help Files for gnome-games which provides the instruction for playing each game.

With the Help Files for gnome-games installed, use the menus to navigate to System > Help > Games to view a list of the available games. There is a brief description along with a link to details about playing each game. The detailed instructions can also be found from the Help > Contents menu in each game.

The games included in the GNOME games pack include:

**Aisle Riot Solitaire**
A collection of dozens of solitaire games

**Blackjack**
The classic casino card game

**Chess**
Play the classic board game against the computer or a friend

**Five or More**
A version of the popular Color Lines game

**Four-in-a-Row**
A four-in-a-row game played against the computer or another human opponent

**FreeCell Solitaire**
Another huge collection of solitaire games

** GNOME Falling Blocks**
Create a complete horizontal row of blocks which will disappear

**Hearts**
A trick-taking card game. Try to gain as few point cards as possible
Chapter 13. Playing games

Iagno
   A Reversi-like disk flipping game

Klotski
   A group of sliding block puzzles

Mahjongg
   A tile-matching game with many variations

Mines
   A clone of a popular puzzle game

Nibbles
   A worm or snake game

Robots
   The classic game of out-of-control robots

Same GNOME
   A puzzle game involving the strategic removal of groups of marbles

Sudoku
   The popular logic puzzle

Tali
   A poker game played with dice

Tetravex
   A simple tile-matching game

13.2. Default KDE games

Many KDE games are not installed by default from the Live-CD or the DVD. If you do not have access to the Internet, you can use the Fedora DVD to install them, either using the PackageKit application or on the command line by using Yum. Refer to Chapter 17, Managing software for help installing new software.

The games included in the KDE games pack include:

Bomber
   An arcade bombing game

Bovo
   Five in a row game

Kapman
   Pac-man type game

KAtomic
   Fun and educational game built around molecular geometry

KBattleship
   Battleship strategy game
KBlackBox
   Find the balls hidden in the black box by shooting laser beams

KBlocks
   A falling block game

KBounce
   The classic game of segregating bouncing balls

KBreakout
   Break-out type game

KDiamond
   Three in a row game

KFourinLine
   Four in a row board game

KGoldrunner
   A Lode Runner type of game

Killbots
   Evade killer robots

Kiriki
   A Yahtzee like dice game

KJumpingCube
   A territory capture game

KMahjongg
   A Mahjongg game

KMines
   A game similar to Mines

KNetWalk
   A network construction game

Kolf
   A little mini-golf game

Kollision
   A ball dodging game

Kolor Lines
   A little game about balls and how to get rid of them

Konquest
   A galactic space game

KPatienc
   Has several card games
Chapter 13. Playing games

KReversi
Reversi board game

KsirK
A world domination game

KSpaceDuel
The challenging space duel

KSquares
Connect the dots to make squares

KSudoku
Sudoku game

Kubarick
3D game based on Rubik's Cube

LSkat
A card game

Potato Guy
A children's picture game

SameGame
Board game

Shisen-Sho
A mahjongg like game
Managing photos

Most USB-compatible cameras will work automatically with Fedora and require very little configuration. If your digital camera offers a choice of USB connection types, set the camera's USB setting to PTP, or point-to-point mode. Consult your camera's user manual to determine if this option is available and how to choose it. If it is not available, the default settings should be sufficient.

14.1. Connecting Your camera

To connect the camera to your Fedora system:
1. Make sure your camera is powered off.
2. Connect a USB cable from the camera to your computer.
3. If your camera requires you to select a knob or dial setting before connecting it to a computer, make that selection now.
4. Power the camera on.

When your camera powers on, Fedora will recognise the device and launch any software that you have configured to import and manage photos, for example the gThumb Image Viewer and F-Spot Photo Manager on the GNOME desktop or the digiKam photo management program on the KDE desktop.

14.2. Managing photos on the GNOME desktop

After your camera powers on, an informational window should appear on your desktop. From the drop-down menu you can select:
• Open with gThumb Image Viewer and choose Import Photos.
• Open with F-Spot Photo Manager and select Copy.
• Open with Other Application and select the appropriate application.

If you decide you do not want to import photos, click the Do Nothing button. If you do not want to see this dialog each time you connect a camera, you can select the Always perform this action option in conjunction with the gThumb Image Viewer or F-Spot Photo Manager button to make one of the choices permanent.

Other ways of accessing your photos are:
• Click on the desktop device icon that contains the photos.
• Click Places > on the top menu bar, and then click the camera or other device that stores your photos.

14.2.1. Organizing and importing photos

After you make your selection, Fedora loads thumbnails, or previews, of the photos from your camera into the Import Photos window. From this new window, you can:
• Give Fedora a Destination for the imported images.
• Assign Categories from the drop-down menu.
Chapter 14. Managing photos

• Deselect imported images from the camera.
• Keep original File names.
• Rotate the images.

In this dialog, you can select or deselect photos to import by clicking on the corresponding thumbnail. To select all photos, click any photo and then press the key combination Ctrl+A. To deselect all photos, press Ctrl+Shift+A. Once you have selected all the photos that you want to import, click the Import button. To cancel the entire import process, click the Cancel button. For a more detailed explanation of the options available when importing images, see the information below.

If you accidentally disconnect your camera

The camera button allows you to reload the thumbnails in case your camera is accidentally disconnected from the computer. If that happens, Fedora may display an additional dialog that returns you to the previous step. It is safe to click Ignore in that dialog, return to this one, and click the camera button again.

14.2.1.1. Selecting a Filing Method

Use Destination to select a folder in which to keep your photo images. Within a destination folder, you can further organize your photos by date and time, or by any other method you wish. If you enter text into the Film box, Fedora uses this text to label and organize the photos you import.

If you want Fedora to delete the images from your camera after it imports them, select Delete imported images from the camera. If you want it to use the filenames from the camera, select Keep original filenames. If you do not select this box, Fedora automatically numbers your images using the order it imports them, starting with 00001.

14.2.1.2. Categorizing your photos

The Categories box shows any special category labels you select to mark the photos you import. If you want to select any categories for your photos, click the ... button on the drop-down bar, which makes the category selection dialog appear.

To label your images with a category, click the checkbox next to the category name. Select as many as you want. If you do not see a category name you like, select the New button and enter a new category name to add to the list. If you want to remove a category name permanently from the list, select the category by clicking on its name and then click Delete.

As you select categories, they appear in the Selected categories box. When you are finished, click OK to save the category names, or Cancel to forget any category selections.

Selecting a category using a checkbox protects filing choices.

It is easy to accidentally misfile images due to a typing mistake. By using checkbox selection, images are correctly categorized every time.
14.3. Managing photos on the KDE desktop
The KDE desktop uses digiKam to import and organize your photos. Digikam also provides image editing features through the showFoto program.

When you turn on a camera connected to your computer, or plug in device containing photos such as a USB flash drive, Fedora will notify you by opening a window from the Device Notifier located at the left of the KDE panel. If you do not see a window, click the Device Notifier to open the window manually. You should see the camera or other storage device listed in the window. Click on the device, and a dialog box will open to ask What do you want to do? Click Download Photos with digiKam and OK.

14.3.1. Importing photos with digiKam
When you first start digiKam, it prompts you for a default location in which to store your photos, and will suggest the Pictures folder inside your Home folder. It will also ask for a location to store a database that it will create to store information about your photos. Digikam will use this database to help you organise and manage your photos and will again suggest the Pictures folder as the location for this database. For both the default picture location and the database location, you can type in the name of a folder on your computer, browse to a folder by clicking on the folder icon, or accept the defaults. When you have made your choices, click OK and the main digiKam window will open, together with a separate window to show you the files on the camera or storage device.

In this dialog, you can select or deselect photos to import by clicking on the corresponding thumbnail. To select all photos, click any photo and then press the key combination Ctrl+A. To deselect all photos, press Ctrl+Shift+A. Once you have selected all the photos that you want to import, click the Download Selected button. To cancel the import process before you begin the download, close the window. To cancel the process once the download is underway, click the Cancel button.

Digikam asks you for a name for this group of pictures, which it calls an album. Either click on an existing album on the list, or click New Album and provide a name for the album. Digikam will suggest the current date as a name for the album, but you might want to choose a name that will better help you to remember the subject of these photos. When you have selected an album, click OK and digiKam will import the photos to your computer.

To clear the photos from your camera, click Image > Delete Selected to delete just the images you imported to your computer, or click Image > Delete All to delete all images from your camera.

14.3.2. Organising photos with digiKam
A tag is a piece of information that you add to digiKam’s database that helps you to identify a photo again in future. For example, you might tag a photo with the names of the people who appear in it, the location at which the photo was taken, or the name of an occasion.

To tag an image, right-click on it, then click Apply Tag, then place checks against one or more tags from the list. To add a new tag to the list, click Add New Tag and then apply it to the photo. When digiKam displays the image in future, any tags that you have applied will appear below the picture. Applying tags does not alter the photo itself, and you will not damage your photo by tagging it. Digikam stores tags separately from the photos.

To search for images with a particular tag, click the Search button, type the tag into the search box, and press Enter. Digikam will display all the images to which you have applied that tag.
Sharing your desktop

Use this capability carefully
Remote desktop sharing can be a serious security risk. You should leave it turned on only when needed and should not leave it active.

Fedora lets you share your desktop remotely across a network, so that a user at a different computer can view and – with your permission – interact with your computer. This is useful for receiving technical support from a remote location or for demonstrating a desktop feature to another user. You may also find it to be a useful way to remotely access files on your desktop from another computer.

Fedora uses a method called Virtual Networking Computing (VNC) to enable remote desktop sharing. Therefore, the remote viewer must use VNC as well. Apple OS X uses VNC by default, but Microsoft Windows uses a different method to share desktops, called Remote Desktop Connection (RDC). To access your Fedora desktop from a computer with a Microsoft Windows operating system, that computer will need a VNC viewer. TightVNC is a free and open-source VNC program available for Linux and Microsoft Windows from http://www.tightvnc.com/.

15.1. GNOME
To activate desktop sharing, select System > Preferences > Remote Desktop from the user menu. This opens the Remote Desktop Preferences window.

To share your desktop securely:
1. Under Sharing, tick the box labeled Allow other users to view your desktop.
2. Next, tick the box next to Allow other users to control your desktop.
3. Make a note of the command listed under Users can view your desktop using this command.
4. Under Security, tick the box next to Ask you for confirmation.
5. Next, check Require the user to enter this password and enter a password. This should not be your account’s password; pick a new password that you will only reveal to the remote viewer.
6. Finally, click on the Close button.

Be sure to inform the person performing remote technical support or remote viewing the command from step three, as well as the assigned password. When the person connects to your desktop, click on the Yes button when asked for confirmation.

Once the remote viewing feature is no longer needed, turn off desktop sharing:
1. Select System > Preferences > Remote Desktop.
2. Uncheck the Allow other users to view your desktop box.
3. Click the Close button.
Chapter 15. Sharing your desktop

15.2. KDE

To activate desktop sharing in KDE, select Kickoff Application Launcher > Applications > System > Desktop Sharing. This opens the Desktop Sharing control module window. There are two methods by which you can share your desktop:

- You can create an invitation. By default, invitations are only valid for one hour. This lessens the chance of forgetting to disable Desktop Sharing, and is a good option if you only need it enabled temporarily.

- You can leave Desktop Sharing turned on at all times.

To create a Desktop Sharing invitation, open the Desktop Sharing window as described above, click New Personal Invitation and give the information to the person you want to invite.

If you want to have Desktop Sharing running at all times:
- In the Desktop Sharing window, click Configure > Security then check the box Allow uninvited connections.

- Next, check Confirm uninvited connections before accepting (optional, but recommended).

- Check Allow other users to control your desktop.

- A password should be set for security; enter one in the box at the bottom of the window. This should not be your user account password.

- Select the Network tab at the top of the window, check Use default port and make a note of the port listed.

- Finally, click on the Apply button.

The person connecting to your computer remotely will need your IP address or hostname, followed by a : and the port number that you noted above. When the person connects to your desktop, click on the Yes button when asked for confirmation.

Once the remote viewing feature is no longer needed, turn off desktop sharing:
2. Uncheck the Allow uninvited connections box.
3. Click the Apply button.

15.3. Other desktops

Various desktop environments may offer their own graphical assistants for desktop sharing, but the VNC server program can be used from the command line to accomplish this task on almost any desktop environment. Setting up this service is beyond the scope of this guide.
Customizing the desktop

Fedora allows you to customize the “look and feel” of your desktop environment. All of the settings that determine the appearance of your desktop are referred to collectively as a theme.

16.1. Changing the theme

Most desktop environments, including GNOME and KDE, allow you to install new themes to tweak the appearance of the desktop. The process for installing a theme varies for each desktop. You can find the process for installing themes under GNOME and KDE in this chapter, and most desktop environments include installation instructions in their own documentation.

16.1.1. Changing the theme in GNOME

To change the desktop theme, choose System > Preferences > Appearance. The Theme Preferences window appears. To change the theme, select one from the list, the theme will be applied automatically.

Fedora’s repositories include many other themes that you can install, in the gnome-themes-extra package. You can install gnome-themes-extra by either using the PackageKit or on the command line by using Yum. Refer to Chapter 17, Managing software for instructions.

When the gnome-themes-extra is installed on your computer, the themes can be selected by using the Appearance program described in this section.

16.1.2. Changing the theme in KDE

By default KDE uses Oxygen as its theme, with many more available from http://www.kde-look.org/.

To change the theme, click Kickoff Application Launcher > Computer > System Settings > Appearance. Expand the Appearance item and click Style.

To change the theme, select one from the list and click the Apply button at the bottom of the window.

You can download additional icons and themes for KDE by installing the kdeartwork-icons and kdeartwork packages. You can install these packages by either using the PackageKit or on the command line by using Yum. Refer to Chapter 17, Managing software for instructions.

16.2. Changing the background

16.2.1. Changing the background in GNOME

To change the background image on your desktop, right-click on an empty area of the desktop, and select the Change Desktop Background option. The Desktop Background Preferences window appears. To change your desktop background, choose a new image from the list. You can add your own images by clicking the Add button.

To set a color or gradient, select Vertical gradient and make your choice of Solid color, Horizontal gradient, or Vertical gradient. Then click the color bars next to the gradient window and select the colors you want.
16.2.2. Changing the background in KDE
To change the background in KDE, right click an empty area of the desktop, and select the Appearance Settings option. When the Desktop Setting - Plasma Workspace window appears, you can select a new theme and wallpaper from the drop-down menus, or get new ones by clicking the New theme... or Get New Wallpapers... buttons.

16.3. Customizing file browsing behavior

16.3.1. Customizing file browsing behavior in GNOME
By default, GNOME uses the Nautilus file manager, which opens a new window each time you open a folder. You can change this behavior to use one window with Forward and Back buttons.

To change this, double-click on Computer on the desktop, click Edit and then Preferences. You can also select Places > Computer > Edit > Preferences from the menu panel. Click the Behavior tab and click on the box next to the text Always open in browser windows.

To install a program that modifies several aspects of using Nautilus. Install Gtweakui which enables you to modify your GNOME desktop quickly and easily.

Applications > Add/Remove Software then searching for gtweakui will provide the program to install. The program's location can be found under System > Preferences.

16.3.2. Customizing file browsing behavior in KDE
By default, KDE uses the Dolphin file manager. To modify the appearance of Dolphin windows, open the program by clicking the Kickoff Application Launcher > Applications > System > File Manager icon for Dolphin. At the top of the Dolphin window, click Settings > Configure Dolphin. The tabs in the Dolphin Preferences window allow you to specify the folder that Dolphin displays when it starts, the size of the icons it displays, the font it uses to label icons, and many other options.

16.4. Compiz-Fusion
The Compiz Fusion Project brings 3D desktop visual effects that improve usability of the X Window System and provide increased productivity though plugins and themes contributed by the community giving a rich desktop experience.

Note
There may be problems with running Compiz Fusion if you do not have a 3D-capable video card.

The Fedora Project does not enable Compiz Fusion by default and therefore, if you want to use it, you will need to install it first. Refer to Chapter 17, Managing software for instructions on managing software. You will need the compiz-gnome or compiz-kde depending on which desktop you use.

When you have installed Compiz Fusion, you can launch the program by selecting System > Preferences > Look and Feel > Desktop Effects in GNOME or Kickoff Application Launcher > Applications > Settings > Compiz Switcher in KDE.
16.5. Widgets

16.5.1. GDesklets

GDesklets are Calendar, Weather, and Quote of the day widgets for the GNOME desktop. To install them go to Applications > Add/Remove Software then go to the Search tab and search for gdesklets. GDesklets is the program that needs to be installed and the other programs listed are the plugins. You will need to install both GDesklets and the GDesklets-goodweather plugin. They can also be installed by using Yum at the command line.

When you have installed the software, you can access GDesklets by going to Applications > Accessories > Gdesklets. This will load up a program with all available plugins. Select the uncategorized category and double-click GoodWeather Display.

After a few moments the the desklet will appear on the desktop and allow you to move it to a preferred location on the desktop.

Note
Where you initially place it is not important. The desklet can be moved at any time by right-clicking on the desklet and choosing move desklet.

To configure the weather gdesklet, right-click and select configure desklet. A dialog will appear with general settings. Modifying the location can be done by going to http://www.weather.com/. At the very top of the weather.com website is a search box for local weather information. Type in the location. After searching the code for the location will be found in the url. For example, the weather for Perth, Australia is at the following link: http://www.weather.com/outlook/travel/business/traveler/local/ASXX0089?from=search_city.

To use that information, note the location code – in this example, ASXX0089 – enter it into the weather desklet, and select Close button. The weather information will be available after the next update interval.

To get additional plugins visit http://gdesklets.de/

16.5.2. KDE plasmoids

Plasmoids are widgets for the KDE desktop. You can add plasmoids by clicking the plasma toolbox icon located at the top right of the desktop or right-hand edge of the panel and then clicking Add Widget. You can also add plasmoids by right-clicking on the desktop and panel and clicking Add Widget.

When you install the KDE desktop, a number of plasmoids are installed on your system by default, although most of them are not visible until you add them to your desktop or panel. These include various clocks, calendars, small games, and widgets that present you with information about the status of your computer hardware or about multimedia files as you play them. When you click the Add Widget menu option, the plasma toolbox presents you with a list of the widgets currently available to you, along with short descriptions of each one. The plasma toolbox also gives you the option to Install New Widgets either by downloading from KDE-Look.org, or by installing ones that you have previously downloaded and saved to your computer.
Managing software

17.1. Using PackageKit
Fedora 12 uses a program called PackageKit to graphically assist the user with installing and removing software. Any application from the Fedora repositories, including the ones described in this user guide, can be installed with the following method.

17.1.1. Installing software
Here is how to install software using Add/Remove Software in the GNOME desktop environment.

Click System > Administration > Add/Remove Software. This will open the Add/Remove Software application.

In the Search Box with the binoculars icon, type the name of the application you wish to install. If you are unsure of the specific application you need to install, you can also type keywords in this box, just like you would for an internet search engine.

Next, click the Find – The message Querying appears in the lower left corner.

Zero or more listings will appear that match your search query. Tick the box next to the description of the application or applications you wish to install. The message Downloading repository information appears in the lower left corner. The window area below the list of packages contains additional information about the selected software.

Select any additional packages to install or remove at this time by changing tick boxes next to the package name.

Finally, click the Apply button. This starts the installation process and concurrently installs or removes any additional packages where you modified the tick box. Follow any prompts to install additional packages.

Unless an error is displayed, the application is now installed on your computer.

17.1.2. Removing software
To remove software using PackageKit, you should follow the standard installation procedure, but untick boxes beside the programs you wish to uninstall instead of ticking boxes to install new programs.

Click System > Administration > Add/Remove Software. This will open the Add/Remove Software application.

In the Search Box with the binoculars icon, type the name of the application you wish to remove. If you are unsure of the specific application you need to remove, you can also type keywords in this box, just like you would for an internet search engine.

Next, click the Find button. The message Querying appears in the lower left corner.

Zero or more listings will appear that match your search query. Untick the box next to the description of the application or applications you wish to remove.
Chapter 17. Managing software

Software Installed Outside of PackageKit
If the box is already unticked, then the program is probably not already installed. If you are sure that you’ve selected the right application, but it still appears to not be installed, then it may have been installed using a method other than PackageKit. If, for example, the program was compiled and installed from source, then it may not register as installed in PackageKit. If this is the case, you will need to find an alternate method of removing it. If it was installed from source, you may find more information in the source distribution’s Readme file.

The message Downloading repository information appears in the lower left corner. The window area below the list of packages contains additional information about the selected software.

Select any additional packages to install or remove at this time by changing tick boxes next to the package name.

Finally, click the Apply button. This starts the removal process and concurrently installs or removes any additional packages where you modified the tick box. Follow any prompts to remove additional packages, such as dependencies that only your newly uninstalled program relied upon.

Unless an error is displayed, the application is now removed from your computer.

17.2. Using the command line interface
Another way to install or remove an application is to use the command line and Yum, the Yellowdog Update Manager. This can be a much faster process than the PackageKit method, but requires the user to use the command line. If this feels uncomfortable, the PackageKit method may be a more familiar way to manage software.

17.2.1. Installing software
Click Applications > System Tools > Terminal to open the command line.

Type:

```
su -c 'yum install application'
```

Where application is the name of the program you wish to install.

If you are unsure of the exact name of your desired installation, you can search your installed repositories for a keyword:

```
su -c 'yum search keyword'
```

Where keyword is the word you wish to search for among the names and descriptions of programs in the available repositories.

After using the yum install command, you will be prompted for the computer's root password. Type in the root password and press Enter. You will not see the password as you type. The terminal will start giving information about the application, and end with Is this ok [y/N]:.Oftentimes, the
Removing software

The installation of an application will require that other programs, called dependencies, are installed as well. These are programs or utilities upon which your selected application relies.

If you wish to continue installation after seeing the dependencies and their disk space requirements (which may be unexpectedly considerable), type:

```
y
```

The terminal downloads the necessary files and completes the installation of your application.

17.2.2. Removing software

Click Applications > System Tools > Terminal to open the command line.

Type:

```
su -c 'yum remove application'
```

Where application is the name of the program you wish to remove.

If you are unsure of the exact name of your desired installation, you can search your installed repositories for a keyword:

```
su -c 'yum search keyword'
```

Where keyword is the word you wish to search for among the names and descriptions of programs in the available repositories.

After using the yum remove command, you will be prompted for the computer's root password. Type in the root password and press 'Enter'. You will not see the password as you type. The terminal will start giving information about the application, and end with Is this ok [y/N]: If dependencies that were installed with the application are unneeded by other applications, you may be prompted to remove these as well.

If you wish to continue the software removal, type:

```
y
```

The terminal deletes the necessary files and completes the removal of your application.

17.3. Advanced Yum

Advanced usage

This content is written for the more advanced user. It assumes that you are comfortable with the command line and have a relatively good knowledge of Linux terminology. It is
Use the **Yum** utility to modify the software on your system in four ways:

- to install new software from package repositories.
- to install new software from an individual package file.
- to update existing software on your system.
- to remove unwanted software from your system.

### Installing Software from a Package File

The **Yum** commands shown in this section use repositories as package sources. **Yum** can also install software from an individual package file. This advanced usage is beyond the scope of this Guide.

To use **Yum**, specify a function and one or more packages or package groups. Each section below gives some examples.

For each operation, **Yum** downloads the latest package information from the configured repositories. If your system uses a slow network connection yum may require several seconds to download the repository indexes and the header files for each package.

The **Yum** utility searches these data files to determine the best set of actions to produce the required result, and displays the transaction for you to approve. The transaction may include the installation, update, or removal of additional packages, in order to resolve software dependencies.

This is an example of the transaction for installing **tsclient**:

```
Package Arch Version Repository Size
-----------------------------------------------
Installing:
tsclient i386 0.132-6 base 247 k
Installing for dependencies:
  rdesktop i386 1.4.0-2 base 107 k

Transaction Summary
-----------------------------------------------
Install  2 Package(s)
Update  0 Package(s)
Remove  0 Package(s)
Total download size: 355 k
Is this ok [y/N] :
```

**Example 17.1. Format of Yum transaction reports**

Review the list of changes, and then press **Y** to accept and begin the process. If you press **N** or **Enter**, **Yum** does not download or change any packages, and will exit.
Installing new software with Yum

Package Versions

The Yum utility only displays and uses the newest version of each package, unless you specify an older version.

The Yum utility also imports the repository public key if it is not already installed on the rpm keyring. For more information on keys and keyrings, refer to the Fedora Security Guide.

This is an example of the public key import:

Example 17.2. Format of Yum public key import

Check the public key, and then press Y to import the key and authorize the key for use. If you press N or Enter, Yum stops without installing any packages. Ensure that you trust any key’s owner before accepting it.

To ensure that downloaded packages are genuine, Yum verifies the digital signature of each package against the public key of the provider. Once all of the packages required for the transaction are successfully downloaded and verified, yum applies them to your system.

Transaction Log

Every completed transaction records the affected packages in the log file /var/log/yum.log. You may only read this file with root access.

17.3.1. Installing new software with Yum

To install a generic package my-package, enter the command: su -c 'yum install my-package' Enter the password for the root account when prompted.

To install a package group PackageGroup, enter the command: su -c 'yum groupinstall "PackageGroup"' Enter the password for the root account when prompted. Examples of package groups include MySQL Database and Authoring and Publishing.

New Services require Activation

When you install a service, Fedora does not activate or start it. To configure a new service to run on bootup, choose System > Administration > Services from the top desktop panel, or use the chkconfig and service command-line utilities. See the man pages for more details.
17.3.2. Updating software with Yum
To update the generic package *my-package* to the latest version, type: `su -c 'yum update my-package'` Enter the password for the root account when prompted.

New Software Versions Require Reloading
If a piece of software is in use when you update it, the old version remains active until the application or service is restarted. Kernel updates take effect when you reboot the system.

Kernel Packages
Kernel packages remain on the system after they have been superseded by newer versions. This enables you to boot your system with an older kernel if an error occurs with the current kernel. To minimize maintenance, yum automatically removes obsolete kernel packages from your system, retaining only the current kernel and the previous version.

To update all of the packages in the package group *PackageGroup*, enter the command: `su -c 'yum groupupdate "PackageGroup"'` Enter the password for the root account when prompted.

Updating the Entire System
To update all of the packages on your Fedora system, use the command: `su -c 'yum update'` Enter the password for the root account when prompted.

17.3.3. Removing software with Yum

Data and Configuration File Retention
The removal process leaves user data in place but may remove configuration files in some cases. If a package removal does not include the configuration file, and you reinstall the package later, it may reuse the old configuration file.

To remove software, *Yum* examines your system for both the specified software, and any software which claims it as a dependency. The transaction to remove the software deletes both the software and the dependencies.

To remove the generic package *my-package* from your system, use the command: `su -c 'yum remove my-package'` Enter the password for the root account when prompted.

To remove all of the packages in the package group *PackageGroup*, enter the command: `su -c 'yum groupremove "PackageGroup"'` Enter the password for the root account when prompted.
Appendix A. Contributors and production methods

A.1. Contributors

- Arnes Arnautovic\(^1\) (translator - Bosnian)
- John Babich\(^2\) (writer)
- Laura Bailey (editor)
- Jonathan Barrios\(^3\) (translator - Spanish)
- Domingo Becker\(^4\) (translator - Spanish)
- Matt Bird\(^5\) (writer)
- Héctor Daniel Cabrera\(^6\) (translator - Spanish)
- Thomas Canniot\(^7\) (translator - French)
- Nicolas Corrarello\(^8\) (writer)
- Bart Couvreur\(^9\) (writer, editor)
- Matthew Daniels\(^10\) (writer, editor)
- Cody DeHaan (writer, editor)
- Michel Duquaine\(^11\) (translator - French)
- Damien Durand\(^12\) (writer)
- Eddie Elizondo\(^13\) (editor)
- Paul W.Frields\(^14\) (writer)
- Jorge A Gallegos\(^15\) (translator - Spanish)
- Scott Glaser\(^16\) (writer)
- Dimitris Glezos\(^17\) (editor)
- Guido Graziol\(^18\) (translator - Italian)
- Zachary Hamed\(^19\) (writer)
- Alexey Kostyuk\(^20\) (translator - Russian)
- Tim Kramer (writer, editor)
- Ruediger Landmann\(^21\) (writer, editor)
- Susan Lauber\(^22\) (writer, editor)
Appendix A. Contributors and production methods

- Jens Maucher\textsuperscript{23} (translator - German)
- microcai (translator - Chinese, Simplified)
- Dan O'Brien\textsuperscript{24} (writer)
- Jonathan Roberts\textsuperscript{25} (writer)
- Misha Shnurapet\textsuperscript{26} (translator - Russian)
- Tian Shixiong (translator - Chinese, Simplified)
- Thomas Spura\textsuperscript{27} (translator - German)
- Sulyok Péter\textsuperscript{28} (translator - Hungarian)
- Dennis Tobar\textsuperscript{29} (translator - Spanish)
- Karsten Wade\textsuperscript{30} (editor)
- Geert Warrink\textsuperscript{31} (translator - Dutch)
- Marc Wiradiashastra\textsuperscript{32} (writer)
- Yangkejin (translator - Chinese, Simplified)
- Kirk Ziegler\textsuperscript{33} (writer, editor)

http://docs.fedoraproject.org/user-guide/

A.2. Production methods

Writers produce the User Guide in MediaWiki and export it to DocBook XML in a revision control repository. They collaborate with other subject matter experts during the beta release phase of Fedora to describe and explain what Fedora offers to people using Fedora to carry out common desktop computing tasks. The editorial team ensures consistency and quality of the finished guide. At this point, the team of translators produces other language versions of the release notes, and then they become available to the general public as part of Fedora. The publication team also makes the guide, and subsequent errata, available via the Web.
## Appendix B. Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Authors</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.0.0</td>
<td>Thu Oct 01 2009</td>
<td>Ruediger Landmann</td>
</tr>
<tr>
<td></td>
<td>Update for Fedora 12</td>
<td></td>
</tr>
<tr>
<td>11.0.0</td>
<td>Thu Apr 23 2009</td>
<td>Laura Bailey, Matthew Daniels, Tim Kramer,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Ruediger Landmann, Susan Lauber, Kirk Ziegler</td>
</tr>
<tr>
<td></td>
<td>Update for Fedora 11, Convert to Docbook XML</td>
<td></td>
</tr>
<tr>
<td>0.6.0</td>
<td>Sat Feb 24 2007</td>
<td>Matt Bird, Cody DeHaan, Damien Durand, John</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Babich, Paul W. Frields, Dimitris Glezos, Bart</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Couvreur</td>
</tr>
</tbody>
</table>

Version for Fedora Core 6