Product SiteDocumentation Site

4.3.3. Prevent a Package from Being Updated

This is optional, and recommended only for advanced users. yum normally installs the latest version of packages. This plugin prevents certain packages from being updated. If you wish to prevent packages from a particular repository from being used, then Section 4.3.2, “Set Repository Priorities” is better-suited to your needs.
  1. Install the yum-plugin-versionlock package.
  2. Use a text editor or the cat or less command to verify that /etc/yum/pluginconf.d/versionlock.conf exists, and contains the following text: enabled = 1
  3. Add the list of packages which you do not want to be updated to /etc/yum/pluginconf.d/versionlock.list. Each package should go on its own line. For example:
    jack-audio-connect-kit-1.9.4
    qjackctl-0.3.6