Product SiteDocumentation Site

8.4.6. Creating our Theme

I want something simple, to match the simple-sounding chorale at the beginning that is the theme of this movement. What could be simpler than a moment of sound, followed by some moments of silence?
  1. In the MIDI matrix editor window, click on the "Edit mode" tool, which looks like a pencil with no other markings.
  2. I decided to place a note every three beats (one beat is marked by one vertical line), on the beat, lasting for one sixteenth note.
    1. Click the pencil where you want the note to appear. A box will appear. If you drag the box to the right, then the note will sound for longer.
    2. I put all of the notes on the same pitch, but it doesn't matter whether you put them on the same pitches or not - they will be changed later.
    3. I also made a mistake when I was inputting the notes, so there's one place where they are only two beats apart instead of three. This didn't matter to me, but it might matter to you.
    4. Continue inputting notes until you have filled the whole pre-selected region (between the blue markers). Qtractor will let you continue beyond that point, so you need to keep an eye on the marker yourself.
    5. To scroll sideways, you can hold down either Shift or Ctrl and use your mouse's scroll wheel.
  3. Move to transport just before the end of the segment you added: use Shift-click.
  4. Listen to the end to ensure that your segment ends with or before the end of the first formal area.
  5. Close the matrix editor window.
  6. Use the main window to view the MIDI segment which you just inputted. The vertical lines represent barlines, and the darker rectangles represent notes.
  7. If the MIDI segment extends beyond the last note that you inputted, click-and-drag the end so that there isn't much over-hang. If you accidentally adjust it too far and remove notes, then simply drag the segment back out - the notes should still be there.
  8. Return to the matrix editor by double-clicking on the MIDI segment.
  9. Select all of the notes that you have inputted so far:
    • Press Control-a
    • Click-and-drag to select, or
    • Click on 'Edit > Select > Select All'
  10. Randomize the pitches:
    1. Click on 'Tools > Randomize'
    2. Ensure that "Randomize" is checked
    3. Ensure that "Note" is checked (this means "pitch")
    4. Choose a percentage.
    5. Click "OK" to apply.
    6. You may need to experiment with the percent of randomization that you allow. Greater randomization means a lower chance of repetition, but it also means that the pitches will be spread within a smaller range.
    7. If you want to re-try the randomization, click on 'Edit > Undo Randomization', then use the "Randomize" tool again.
    8. If you like what happens to most of the pitches, you can select and move a few of them either individually or together. To adjust pitches as a group, select the ones that you want to move (either by click-and-drag select or by Control-click select), and Control-drag them to the desired new location.
  11. Now you need to adjust the volume of the pitches. There are two ways to do this:
    • You can select all of the pitches, then use the "Resize MIDI" tool, adjusting the "Value" property.
    • You can select all of the pitches, then use the value editor portion of the matrix editor window. This is at the bottom of the matrix editor window, and the height of each pitch shown here tells you the volume at which it will play. To adjust all of the pitches at once, Control-drag to adjust the height as desired. Be careful when doing this that you don't change the horizontal position, which will change the time that the notes sound.
    • I would suggest at volume of approximately "32," but this depends on your taste. Also, I adjust the volume of some pitches to be louder when the audio file is louder.
  12. When you are satisfied with your pitches and volumes, start the transport from the beginning, and listen to the entire segment that you just created. You can change the section again or move on to the next step.