Distribution-wide Changes

Deprecated packages in 389 Console have been removed

In Fedora 31, the following deprecated packages have been removed:

  • 389-console

  • 389-ds-console

  • 389-admin-console

  • 389-dsgw

  • 389-admin

  • 389-adminutil

The packages above are for old Java UI, which was replaced by a web UI for 389 Directory Server.

RPM version 4.15

Fedora now provides the RPM package management utility of version 4.15. For more details see the System Utilities section.

RPM now uses zstd compression

The compression algorithm for the RPM packages has been changed to zstd with compression level 19. Users will benefit from faster package decompression. However, this comes at the expense of a slightly longer package build time.

The compression method for the Source RPM (SRPM) payload is still gzip.

Dynamic BuildRequires

BuildRequires can now be generated automatically for packages in Fedora. See the Developers section for more information.

YUM 3 was removed

The YUM 3 package manager has been removed from Fedora 31. Fore more details see the System Utilities section.

EFI build of GRUB2 now contains several security-oriented modules

The cryptodisk, luks and verify GRUB modules have been added to the GRUB EFI build to enhance users' trust in integrity of early-launch code.

This change enables users to verify that all files that are read from the disk are properly signed. The feature also allows to employ nearly full disk encryption.

The build process automatically includes the explicit dependencies mpi, gcry_sha1, procfs, archelp. However you need to include also the following implicit dependencies gcry_sha256, gcry_rsa, gcry_rijndael, gcry_serpent, gcry_twofish, gcry_whirlpool.

No more i686 repositories

The i686 repositories are no longer available to users to directly install Fedora 31 on i686 hardware. However, the i686 packages continue to be available in the x86_64 multi-lib repositories.

Users with i686 Fedora installations may want to re-install their systems with the 64-bit version if their hardware is 64-bit capable. Alternatively, they can move to new 64-bit capable hardware.

Xfce installation image for 64-bit ARM

An installation image with the Xfce desktop environment is now available for the 64-bit ARM (AArch64) architecture. The image is useful for systems that do not support hardware graphics acceleration or for other low-performance systems.

The image currently supports the following 64-bit ARM devices:

  • Pine64

  • Raspberry Pi 3

  • 96boards HiKey

  • 96boards Dragonboard 410c

Additionally, Fedora continues to provide the following installation images for 64-bit ARM:

  • Workstation

  • Minimal

  • Server

For more information, see https://arm.fedoraproject.org/.

Many Python 2 packages have been removed

The Python upstream will stop supporting Python 2 on 1 January 2020. For that reason, Fedora gradually removes Python 2 packages from the distribution.

In this release, Python 2 packages that met the following conditions have been removed:

  • The packages contained only Python 2 libraries.

  • No other package depended on these Python 2 packages.

Overall, 873 Python 2 packages have been removed.