자동화

Ansible은 이제 기본으로 파이썬 3를 사용합니다

페도라에서 'ansible' 꾸러미는 파이썬 2 대신에, 기본적으로 *파이썬 3*를 사용하도록 전환됩니다.

자신의 페도라 제어 호스트에서 통신하는 대상 장비에서 사용되는 파이썬을 조정해야 할 수도 있습니다. 당신은 Ansible 문서에 있는 다음 지침에 따라 이를 수행 할 수 있습니다.

이와 같은 변경은 일반적으로 '파이썬 2’와 함께 탑재되지 않는 대상 장비를 더 쉽게 관리 할 수 있을 뿐만 아니라, 페도라에서 'ansible’은 업스트림에 의해 사용되어 새로운 기능과 개선 사항을 개발하는 데 사용하는 파이썬 버전으로 이동 할 수 있습니다. 페도라의 '파이썬 2' 하위 꾸러미가 중단됨에 따라서, 점점 더 많은 개발이 '파이썬 3' 버전으로 이동 할 것입니다. 이와 같은 변경은 페도라 'ansible' 꾸러미를 그와 같은 현실에 반영합니다.

페도라의 'ansible' 꾸러미와 함께 탑재되는 모든 신규 모듈과 핵심 모듈은 '파이썬 3’로 시험되었습니다. 로컬에서 생성된 모듈 또는 플러그인, 또는 다른 커뮤니티 플러그인은 '파이썬 3’로 부드럽게 동작하는데 약간의 조정이 필요 할 수 있습니다.