System Utilities

NTPsec

ntpsec replaces ntp in Fedora 34. ntpsec is designed with the highest security standards in mind and its focus is to be a more secure implementation of ntp. This change improves the overall security of Fedora, as ntp contained a number of vulnerabilities that had been exploited in recent years and were not fixed, nor were fixes considered likely to come soon. ntpsec is an open-source, actively maintained, fork of ntp and improves on it by removing obsolete code, updating the codebase, and adding additional features.

There are not likely to be any visible effects for Fedora users: ntpsec is already almost fully compatible with ntp and so existing settings should continue to function for most users. There are very minor functional changes between ntpsec and ntp, as described here, and so there is the potential for limited problems to occur. If problems do occur, then check system logs from the ntpd service and modify /etc/ntpd/conf as necessary, see the documentation for NTPsec.

The latest version, v1.20, is available in Fedora 34. See the NTPsec project news page for information about the latest version compared to prior releases.

MariaDB 10.5

Fedora 34 provides the mariadb package version 10.5, replacing the 10.4 series in Fedora since Fedora 32.

MariaDB 10.5 introduces several enhancements to improve functionality, compatibility and performance.

Highlights

  • Executables with "mysql*" names changed to "mariadb-*" names. The original names are now symlinks to the new names. More information

  • New storage engine available: Amazon S3

  • New INET6 data type for storing IPv6 addresses.

  • Priviledges are now more granular.

For full information about this release, see the official MariaDB release notes.

Move deprecated bluez utilities to sub-package

Certain number of utilities in the upstream bluez bluetooth package have long been deprecated and no longer receive any updates. The functionality of those utilities was replaced by the core bluetoothctl utility.

In Fedora 34, the deprecated bluez utilities have been moved to a dedicated sub-package to indicate their upstream support status.

The list of utilities being moved are:

  • ciptool

  • gatttool

  • hciattach

  • hciconfig

  • hcidump

  • hcitool

  • rfcomm

  • sdptool